Bug 14378 - Problems with net/core/skbuff.c
Summary: Problems with net/core/skbuff.c
Status: CLOSED CODE_FIX
Alias: None
Product: Networking
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Arnaldo Carvalho de Melo
URL:
Keywords:
Depends on:
Blocks: 14230
  Show dependency tree
 
Reported: 2009-10-11 20:50 UTC by Rafael J. Wysocki
Modified: 2009-10-26 20:56 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.31.2
Tree: Mainline
Regression: Yes


Attachments
another similar oops (120.04 KB, text/plain)
2009-10-13 09:15 UTC, ctrix
Details
another trace (14.88 KB, text/plain)
2009-10-13 09:32 UTC, ctrix
Details

Description Rafael J. Wysocki 2009-10-11 20:50:59 UTC
Subject    : 2.6.31.2 problems with net/core/skbuff.c
Submitter  : Massimo Cetra <mcetra@navynet.it>
Date       : 2009-10-08 14:51
References : http://marc.info/?l=linux-kernel&m=125501488220358&w=4

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 ctrix 2009-10-13 09:15:52 UTC
Created attachment 23382 [details]
another similar oops

Actually i found another oops which is very similar to the previous one.
Here, vserver is not involved, and the problem starts at drbd which lives in kernel space (the other oops started at ocfs2).

Both ocfs2 and drbd make heavy use of network I/O so i guess the problem is something in the network layer.

Anything i can do to help to debugging and solving this issue ?
Comment 2 ctrix 2009-10-13 09:32:59 UTC
Created attachment 23383 [details]
another trace

Here it is another trace, triggered by postfix while doing heavy I/O on another server.
This time drbd and ocfs2 are not involved.
Comment 3 Mark McLoughlin 2009-10-13 11:15:18 UTC
Patch for this posted by Eric:

  http://marc.info/?l=linux-netdev&m=125542939211671
Comment 4 Rafael J. Wysocki 2009-10-26 20:55:45 UTC
On Monday 26 October 2009, Eric Dumazet wrote:
> Rafael J. Wysocki a écrit :
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.31.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=14378
> > Subject             : Problems with net/core/skbuff.c
> > Submitter   : Massimo Cetra <mcetra@navynet.it>
> > Date                : 2009-10-08 14:51 (19 days old)
> > References  : http://marc.info/?l=linux-kernel&m=125501488220358&w=4
> > 
> > 
> 
> This was corrected by commit ed79bab847d8e5a2986d8ff43c49c6fb8ee3265f
> 
> virtio_net: use dev_kfree_skb_any() in free_old_xmit_skbs()

Note You need to log in before you can comment on or make changes to this bug.