Bug 14376 - Kernel NULL pointer dereference/ kvm subsystem
Summary: Kernel NULL pointer dereference/ kvm subsystem
Status: CLOSED CODE_FIX
Alias: None
Product: Virtualization
Classification: Unclassified
Component: kvm (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: virtualization_kvm
URL:
Keywords:
Depends on:
Blocks: 14230
  Show dependency tree
 
Reported: 2009-10-11 20:41 UTC by Rafael J. Wysocki
Modified: 2010-02-08 20:47 UTC (History)
0 users

See Also:
Kernel Version: 2.6.31.1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-10-11 20:41:16 UTC
Subject    : kernel NULL pointer dereference/ kvm subsystem
Submitter  : Don Dupuis <dondster@gmail.com>
Date       : 2009-10-06 14:38
References : http://marc.info/?l=linux-kernel&m=125484025021737&w=4

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-10-12 21:06:08 UTC
On Monday 12 October 2009, dondster@gmail.com wrote:
> Yes, it should still be listed.
Comment 2 Rafael J. Wysocki 2010-02-08 18:50:34 UTC
On Monday 08 February 2010, dondster@gmail.com wrote:
> yes
> 
> On Feb 7, 2010 6:28pm, "Rafael J. Wysocki" <rjw@sisk.pl> wrote:
> > This message has been generated automatically as a part of a report
> 
> > of regressions introduced between 2.6.31 and 2.6.32.
> 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.31 and 2.6.32. Please verify if it still should
> > be listed and let the tracking team know (either way).
Comment 3 Rafael J. Wysocki 2010-02-08 19:48:45 UTC
On Monday 08 February 2010, Avi Kivity wrote:
> On 02/08/2010 07:29 PM, Marcelo Tosatti wrote:
> > On Tue, Oct 06, 2009 at 09:38:05AM -0500, Don Dupuis wrote:
> >    
> >> Kernel 2.6.31.2
> >> x86 64bit
> >>
> >> Running numerous kvm linux guests and noticed this oops in messages
> >> file. This didn't occur in 2.6.30.6
> >>
> >> BUG: unable to handle kernel NULL pointer dereference at 0000000000000028
> >> IP: [<ffffffffa01de29f>] kpit_elapsed+0x30/0x60 [kvm]
> >>      
> > Fixed by ace1546487a0fe4634e3251067f8a32cb2cdc099.
> >
> > Greg, can you please cherry pick to 2.6.31.stable?
> >    
> 
> It's already in, 2.6.31.6 (and I think 31.y is dead).
> 
> Rafael, this is #14376.

Note You need to log in before you can comment on or make changes to this bug.