Bug 14372 - ath5k wireless not working after suspend-resume - eeepc
ath5k wireless not working after suspend-resume - eeepc
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 14230
  Show dependency treegraph
 
Reported: 2009-10-11 20:11 UTC by Rafael J. Wysocki
Modified: 2009-11-17 21:45 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.32-rc[1-2]
Tree: Mainline
Regression: Yes


Attachments
Output of lspci (1.55 KB, text/plain)
2009-10-13 08:54 UTC, Fabio Comolli
Details
Output of lspci -n (528 bytes, text/plain)
2009-10-13 08:54 UTC, Fabio Comolli
Details
Output of dmidecode (11.89 KB, text/plain)
2009-10-13 08:55 UTC, Fabio Comolli
Details

Description Rafael J. Wysocki 2009-10-11 20:11:20 UTC
Subject    : Re: [Bug #13943] WARNING: at net/mac80211/mlme.c:2292 with ath5k
Submitter  : Fabio Comolli <fabio.comolli@gmail.com>
Date       : 2009-10-03 15:36
References : http://lkml.org/lkml/2009/10/3/91

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 ykzhao 2009-10-12 14:31:41 UTC
Hi, Fabio
    Will you please describe the problem more clearly? Please attach the output of dmesg after suspend/resume, acpidump, lspci -vxxx.
    Please double check whether the wifi can work if you do the following test:
     >a. rfkill it off 
     >b. suspend-to-ram -resume 
     >c. rfkill it on

Thanks.
Comment 2 Rafael J. Wysocki 2009-10-12 21:52:14 UTC
On Monday 12 October 2009, Fabio Comolli wrote:
> Still present with -rc4.
> 
> Error is:
> 
> [  690.547660] wlan0: direct probe to AP 00:11:95:09:2c:e0 (try 1)
> [  690.550064] wlan0: direct probe responded
> [  690.550074] wlan0: authenticate with AP 00:11:95:09:2c:e0 (try 1)
> [  690.551629] wlan0: authenticated
> [  690.551663] wlan0: associate with AP 00:11:95:09:2c:e0 (try 1)
> [  690.553289] wlan0: RX AssocResp from 00:11:95:09:2c:e0 (capab=0x451
> status=12 aid=1)
> [  690.553298] wlan0: AP denied association (code=12)
> 
> rfkill-ing the device off and then on fixes the problem.
Comment 3 Len Brown 2009-10-13 01:55:44 UTC
Fabio,
Please identify which EEEPC you have by supplying the output
from lspci and dmidecode.
Comment 4 Fabio Comolli 2009-10-13 08:54:35 UTC
Created attachment 23379 [details]
Output of lspci
Comment 5 Fabio Comolli 2009-10-13 08:54:56 UTC
Created attachment 23380 [details]
Output of lspci -n
Comment 6 Fabio Comolli 2009-10-13 08:55:19 UTC
Created attachment 23381 [details]
Output of dmidecode
Comment 7 Fabio Comolli 2009-10-13 08:55:59 UTC
Len, it's an eeePC 900. Please let me know if you need more details.
Comment 8 Rafael J. Wysocki 2009-10-25 10:45:11 UTC
Fabio, did you have a chance to test the box with 2.6.32-rc5?
Comment 9 Fabio Comolli 2009-10-25 10:56:12 UTC
Hi Rafael.
Yes, same results. dmesg says after resume (I'm reporting only the last lines):

[ 4273.537105] Restarting tasks ... done.
[ 4278.091884] wlan0: direct probe to AP 00:11:95:09:2c:e0 (try 1)
[ 4278.094048] wlan0: direct probe responded
[ 4278.094058] wlan0: authenticate with AP 00:11:95:09:2c:e0 (try 1)
[ 4278.095366] wlan0: authenticated
[ 4278.095399] wlan0: associate with AP 00:11:95:09:2c:e0 (try 1)
[ 4278.097043] wlan0: RX AssocResp from 00:11:95:09:2c:e0 (capab=0x451 status=12 aid=1)
[ 4278.097051] wlan0: AP denied association (code=12)
[ 4316.546704] wlan0: direct probe to AP 00:11:95:09:2c:e0 (try 1)
[ 4316.549075] wlan0: direct probe responded
[ 4316.549086] wlan0: authenticate with AP 00:11:95:09:2c:e0 (try 1)
[ 4316.550407] wlan0: authenticated
[ 4316.550441] wlan0: associate with AP 00:11:95:09:2c:e0 (try 1)
[ 4316.552085] wlan0: RX AssocResp from 00:11:95:09:2c:e0 (capab=0x451 status=1 aid=1)
[ 4316.552093] wlan0: AP denied association (code=1)
[ 4328.177920] wlan0: direct probe to AP 00:11:95:09:2c:e0 (try 1)
[ 4328.180036] wlan0: direct probe responded
[ 4328.180044] wlan0: authenticate with AP 00:11:95:09:2c:e0 (try 1)
[ 4328.181331] wlan0: authenticated
[ 4328.181359] wlan0: associate with AP 00:11:95:09:2c:e0 (try 1)
[ 4328.184091] wlan0: RX AssocResp from 00:11:95:09:2c:e0 (capab=0x451 status=1 aid=1)
[ 4328.184099] wlan0: AP denied association (code=1)

Please note that vanilla -rc5 does not work correctly on my eeepc due to a regression in the eeepc-laptop module. So my -rc5 has a patch reverted (the LKML thread is "[Regression] - 2.6.32-rc5 hangs using rfkill on an eeePC", 9 days ago. You are in copy).
Comment 10 Johannes Berg 2009-10-26 19:14:02 UTC
so after you resume, your AP suddenly no longer likes you?!

can you capture the frame exchange using a sniffer (wireshark) on another machine?
Comment 11 Fabio Comolli 2009-10-26 20:17:25 UTC
Unfortunately I don't have other machines.
Comment 12 Luis R. Rodriguez 2009-11-17 15:53:22 UTC
Have you tried rc7?
Comment 13 Fabio Comolli 2009-11-17 16:31:37 UTC
Yes, it seems to work fine. I'm running it since saturday and I've not been able to reproduce the problem so far. I was planning to test it some more but I think that this regression can be closed.
Comment 14 Luis R. Rodriguez 2009-11-17 16:43:39 UTC
Can someone please close this.
Comment 15 Rafael J. Wysocki 2009-11-17 21:45:57 UTC
Closing.

Note You need to log in before you can comment on or make changes to this bug.