Bug 14356 - NFS dead after series of 10-50 suspend-resume
NFS dead after series of 10-50 suspend-resume
Status: CLOSED UNREPRODUCIBLE
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 blocking
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 12398
  Show dependency treegraph
 
Reported: 2009-10-10 09:46 UTC by warpme
Modified: 2010-12-08 20:14 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.31.3, 2.6.30.5
Tree: Mainline
Regression: Yes


Attachments

Description warpme 2009-10-10 09:46:55 UTC
System is diskless multimedia terminal (minimyth).
Issue is: dead Eth port after series of S3 suspend-resume (10-50 cycles) when NFS is used as share. 
With CIFS all looks OK.
2.6.28.10 works OK (700 cycles tested)

I applied patch for bug 11156 as without it system randomly hangs at resume stage.

dmsg reports:
Oct 10 10:17:25 (none) user.err kernel: ACPI: I/O resource nForce2_smbus [0x2e00-0x2e3f] conflicts with ACPI region SM00 [0x2e00-0x2e3f]
Oct 10 10:17:25 (none) user.info kernel: ACPI: Device needs an ACPI driver
Oct 10 10:17:25 (none) user.info kernel: Linux agpgart interface v0.103
Oct 10 10:17:25 (none) user.err kernel: nForce2_smbus 0000:00:01.1: Error probing SMB2.
Comment 1 Rafael J. Wysocki 2009-10-10 21:13:29 UTC
If everything is correct with CIFS, I guess the problem is somehow related to NFS.
Comment 2 Len Brown 2009-10-13 01:39:42 UTC
Can you confirm that we understand?
CIFS is okay, and NFS is failing, and thus the network interface is
okay and the issues is specific to NFS?
Comment 3 warpme 2009-10-13 16:45:25 UTC
Well,
I have following results for 2.6.31.3.
System is disk/kbd-less network booted appliance so I can control it only by: IR (lirc), VNC and telnet. 

CIFS: 500 S3 cycles: OK

NFS:
-no 11156patch: random hang on S3 resume (black screen, Eth dead)
-with 11156patch: no Eth after 1-40 S3 cycles, but rest seems to be fully functional.

Exactly the same system but with 2.6.28.10+patch11156 - S3 with CIFS/NFS are OK
Comment 4 Florian Mickler 2010-12-08 09:11:14 UTC
Is this still a problem on current kernels?
Comment 5 warpme 2010-12-08 18:53:30 UTC
Hi !

It looks that with 2.6.33 and newer all is OK, albeit I'm not able to tell whivh kernel verssion fixed problem.
Comment 6 Florian Mickler 2010-12-08 20:13:28 UTC
I'm closing this as unreproducible then, thanks. 

If this pops up again, please reopen.

Note You need to log in before you can comment on or make changes to this bug.