Bug 14355 - USB serial regression after 2.6.31.1 with Huawei E169 GSM modem
Summary: USB serial regression after 2.6.31.1 with Huawei E169 GSM modem
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-10 03:07 UTC by Benjamin Herrenschmidt
Modified: 2009-11-17 22:23 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.31.2, 2.6.32-rc3
Tree: Mainline
Regression: Yes


Attachments
2.6.31.1 (+ ubuntu patches) working log (17.61 KB, text/plain)
2009-10-10 03:07 UTC, Benjamin Herrenschmidt
Details
2.6.31.3 non-working log (303.57 KB, text/plain)
2009-10-10 03:09 UTC, Benjamin Herrenschmidt
Details
Log of a E620 modem that is still broken (101.74 KB, application/octet-stream)
2009-11-06 00:51 UTC, Benjamin Herrenschmidt
Details

Description Benjamin Herrenschmidt 2009-10-10 03:07:57 UTC
Created attachment 23323 [details]
2.6.31.1 (+ ubuntu patches) working log

See

http://marc.info/?l=linux-kernel&m=125513456327542&w=2

And associated thread. I'll attach usbmon logs here
Comment 1 Benjamin Herrenschmidt 2009-10-10 03:09:39 UTC
Created attachment 23324 [details]
2.6.31.3 non-working log

This is 2.6.31.3 from stable tree (using ubuntu "upstream" builds). Not working. I stopped the log after a few cycles of the bogus connect/disconnect/connect/disconnect.
Comment 2 Benjamin Herrenschmidt 2009-10-10 03:10:56 UTC
2.6.32-rc3 behaves differently (but still broken), I'll attach logs later.

The logs have been taken by:

 - Booting machine until "idle"
 - Disabling bluetooth (the only other USB thing)
 - Starting the usbmon log using the "0u" file
 - Plugging the device and waiting

In the working case, I waited until network manager showed the modem in the menu, in the non-working case, I waited for dmesg to show a few connect/disconnect cycles.
Comment 3 Andrew Morton 2009-10-10 03:31:30 UTC
marked as a regression...

This is a regression in 2.6.32-rc as well, since 2.6.31 worked OK?
Comment 4 Benjamin Herrenschmidt 2009-10-10 05:50:45 UTC
Yes. 2.6.31 and 2.6.31.1 are ok. 2.6.31.2 and later and 2.6.32-rc3 are bad. I haven't tracked more precisely yet.
Comment 5 Rafael J. Wysocki 2009-10-11 21:43:20 UTC
References : http://marc.info/?l=linux-kernel&m=125513456327542&w=4

Notify-Also : Alan Stern <stern@rowland.harvard.edu>
Notify-Also : Ben Efros <ben@pc-doctor.com>
Comment 6 Benjamin Herrenschmidt 2009-10-15 23:03:47 UTC
Patch now upstream ID b8430e1b82b7e514d76a88eb70a7d8831d50df1e and queued for next -stable
Comment 7 Rafael J. Wysocki 2009-10-27 08:25:45 UTC
On Tuesday 27 October 2009, Benjamin Herrenschmidt wrote:
> On Mon, 2009-10-26 at 19:55 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.31.  Please verify if it still should be listed and let me know
> > (either way).
> 
> Well, the E169 works, though there seem to be a few issues remaining:
> 
>  - There are reports that the E220 is still broken (by the same
> regression, just that the patch that fixes the E169 doesn't fix the
> E220, but since I don't have one of these, I'm waiting for users to send
> dumps instead of just complaining :-)
> 
>  - There's a weird glitch where the E169 tend to only work after being
> plugged the -second- time. The first time, the storage device generally
> shows up but not the ttyS's devices for some strange reason. Not sure
> what's up yet. Yanking it and plugging it back works. Could be timing
> related due to the need to load the module.
> 
> None of that happens with 2.6.31.1
Comment 8 Benjamin Herrenschmidt 2009-11-06 00:51:21 UTC
Created attachment 23672 [details]
Log of a E620 modem that is still broken

Unless I mixed things up with user reports, this is:

lsusb shows: ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem

user reports says:

<<
option 3-1:1.2: GSM modem (1-port) converter detected
usb 3-1: GSM modem (1-port) converter now attached to ttyUSB0
option 3-1:1.1: GSM modem (1-port) converter detected
usb 3-1: GSM modem (1-port) converter now attached to ttyUSB1
option 3-1:1.0: GSM modem (1-port) converter detected
usb 3-1: GSM modem (1-port) converter now attached to ttyUSB2
option: option_instat_callback: error -108
option1 ttyUSB2: GSM modem (1-port) converter now disconnected from ttyUSB2
option 3-1:1.0: device disconnected
option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
option 3-1:1.1: device disconnected
option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
option 3-1:1.2: device disconnected
usb 3-1: reset full speed USB device using uhci_hcd and address 3

This repeats. I also get a "notification" that GSM is disconnected...never connected.
>>

The kernel is supposed to have the 2.6.31.5 fix applied
Comment 9 Benjamin Herrenschmidt 2009-11-06 02:40:20 UTC
Ignore the log, the user was not actually running the fixed kernel :-(
Comment 10 Rafael J. Wysocki 2009-11-16 23:10:05 UTC
Fixed by commit b8430e1b82b7e514d76a88eb70a7d8831d50df1e .

Note You need to log in before you can comment on or make changes to this bug.