Bug 14353 - BUG: sleeping function called from invalid context at kernel/mutex.c:280
Summary: BUG: sleeping function called from invalid context at kernel/mutex.c:280
Status: CLOSED CODE_FIX
Alias: None
Product: Networking
Classification: Unclassified
Component: Wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: networking_wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 14230
  Show dependency tree
 
Reported: 2009-10-08 22:37 UTC by Rafael J. Wysocki
Modified: 2009-10-26 19:56 UTC (History)
0 users

See Also:
Kernel Version: 2.6.32-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-10-08 22:37:37 UTC
Subject    : 2.6.32-rc3 -- BUG: sleeping function called from invalid context at kernel/mutex.c:280 -- 2 locks held by head
Submitter  : Miles Lane <miles.lane@gmail.com>
Date       : 2009-10-05 3:39
References : http://marc.info/?l=linux-kernel&m=125471432208671&w=4
Notify-Also : Johannes Berg <johannes@sipsolutions.net>

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-10-26 19:18:50 UTC
On Monday 26 October 2009, Johannes Berg wrote:
> On Mon, 2009-10-26 at 19:55 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.31.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=14353
> > Subject             : BUG: sleeping function called from invalid context at
> kernel/mutex.c:280
> > Submitter   : Miles Lane <miles.lane@gmail.com>
> > Date                : 2009-10-05 3:39 (22 days old)
> > References  : http://marc.info/?l=linux-kernel&m=125471432208671&w=4
> 
> This should be fixed by a160ee69c6a4622ed30c377a978554015e9931cb.

Note You need to log in before you can comment on or make changes to this bug.