Bug 14336 - [Pardus] Soft Lockup Problem with Attansic Ethernet Card
[Pardus] Soft Lockup Problem with Attansic Ethernet Card
Status: CLOSED CODE_FIX
Product: Networking
Classification: Unclassified
Component: IPV4
All Linux
: P1 high
Assigned To: Stephen Hemminger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-06 22:37 UTC by Erdem Artan
Modified: 2012-06-13 19:32 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.30.8
Tree: Mainline
Regression: No


Attachments
syslog (92.60 KB, application/octet-stream)
2009-10-06 22:41 UTC, Erdem Artan
Details
syslog 2 (274.56 KB, application/octet-stream)
2009-10-07 10:03 UTC, Erdem Artan
Details

Description Erdem Artan 2009-10-06 22:37:12 UTC
I have soft lockup problem with attansic ethernet card while activating eth0 interface.

My ethernet card is 09:00.0 Ethernet controller: Attansic Technology Corp. Device 1063 (rev c0)

If I try to activate eth0 interface while network cable is pluged in, then everything freezes.

If I try to activate eth0 interface while network cable isn't pluged in, then no problem. But, if i plug in, again freezes.

My /var/log/syslog is in attachment.

Anything else?

Regards..
Comment 1 Erdem Artan 2009-10-06 22:41:25 UTC
Created attachment 23291 [details]
syslog
Comment 2 Andrew Morton 2009-10-06 22:55:09 UTC
(switched to email.  Please respond via emailed reply-to-all, not via the
bugzilla web interface).

On Tue, 6 Oct 2009 22:37:13 GMT
bugzilla-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=14336
> 
>            Summary: [Pardus] Soft Lockup Problem with Attansic Ethernet
>                     Card
>            Product: Networking
>            Version: 2.5
>     Kernel Version: 2.6.30.8
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: high
>           Priority: P1
>          Component: IPV4
>         AssignedTo: shemminger@linux-foundation.org
>         ReportedBy: badibere@gmail.com
>         Regression: No
> 
> 
> I have soft lockup problem with attansic ethernet card while activating eth0
> interface.
> 
> My ethernet card is 09:00.0 Ethernet controller: Attansic Technology Corp.
> Device 1063 (rev c0)
> 
> If I try to activate eth0 interface while network cable is pluged in, then
> everything freezes.
> 
> If I try to activate eth0 interface while network cable isn't pluged in, then
> no problem. But, if i plug in, again freezes.
> 
> My /var/log/syslog is in attachment.
> 

From the dmesg output it appears that this card is driven by the atl1c
driver:

Oct  7 00:55:57 baDibere kernel: [  169.943463] atl1c 0000:09:00.0: Unable to allocate MSI interrupt Error: -22
Oct  7 00:55:57 baDibere kernel: [  169.943576] atl1c 0000:09:00.0: atl1c: eth0 NIC Link is Up<100 Mbps Full Duplex>
Oct  7 00:56:22 baDibere kernel: [  194.849361] NVRM: Xid (0001:00): 16, Head 00000000 Count 00003651
Oct  7 00:56:31 baDibere kernel: [  203.849307] NVRM: Xid (0001:00): 16, Head 00000000 Count 00003653
Oct  7 00:56:36 baDibere kernel: [  208.849339] NVRM: Xid (0001:00): 8, Channel 00000003
Oct  7 00:56:41 baDibere kernel: [  213.852320] NVRM: Xid (0001:00): 16, Head 00000000 Count 00003655


The "Unable to allocate MSI interrupt" might be the immediate problem.

Who belongs to MSI interrupt allocation?  PCI?  ACPI?

However the driver does attempt to handle and recover from the MSI
interrupt allocation error so perhaps that's no the cause at all.
Comment 3 Erdem Artan 2009-10-06 23:01:20 UTC
Yesterday, there wasn't any problem but 3 days ago there was same problem.

While there wasn't any problem, if I'm not wrong, both atl1c and atl1e
modules were loaded on boot. But, If I try to load atl1e now, nothing
changes.


Erdem Artan
Comment 4 Jay Cliburn 2009-10-06 23:33:57 UTC
On Oct 6, 2009, at 6:01 PM, Erdem ARTAN wrote:

> Yesterday, there wasn't any problem but 3 days ago there was same  
> problem.
>
> While there wasn't any problem, if I'm not wrong, both atl1c and  
> atl1e modules were loaded on boot. But, If I try to load atl1e now,  
> nothing changes.

The pci_id says your chip is an L1c.  Jie Yang is the maintainer of  
the atl1c driver and is cc'd.

Jay
Comment 5 Jay Cliburn 2009-10-06 23:39:21 UTC
On Oct 6, 2009, at 5:55 PM, Andrew Morton wrote:

>
> (switched to email.  Please respond via emailed reply-to-all, not  
> via the
> bugzilla web interface).
>
> On Tue, 6 Oct 2009 22:37:13 GMT
> bugzilla-daemon@bugzilla.kernel.org wrote:
>
>> http://bugzilla.kernel.org/show_bug.cgi?id=14336
>>
>>            Summary: [Pardus] Soft Lockup Problem with Attansic  
>> Ethernet
>>                     Card
>>            Product: Networking
>>            Version: 2.5
>>     Kernel Version: 2.6.30.8
>>           Platform: All
>>         OS/Version: Linux
>>               Tree: Mainline
>>             Status: NEW
>>           Severity: high
>>           Priority: P1
>>          Component: IPV4
>>         AssignedTo: shemminger@linux-foundation.org
>>         ReportedBy: badibere@gmail.com
>>         Regression: No
>>
>>
>> I have soft lockup problem with attansic ethernet card while  
>> activating eth0
>> interface.
>>
>> My ethernet card is 09:00.0 Ethernet controller: Attansic  
>> Technology Corp.
>> Device 1063 (rev c0)
>>
>> If I try to activate eth0 interface while network cable is pluged  
>> in, then
>> everything freezes.
>>
>> If I try to activate eth0 interface while network cable isn't  
>> pluged in, then
>> no problem. But, if i plug in, again freezes.
>>
>> My /var/log/syslog is in attachment.
>>
>
> From the dmesg output it appears that this card is driven by the atl1c
> driver:
>
> Oct  7 00:55:57 baDibere kernel: [  169.943463] atl1c 0000:09:00.0:  
> Unable to allocate MSI interrupt Error: -22
> Oct  7 00:55:57 baDibere kernel: [  169.943576] atl1c 0000:09:00.0:  
> atl1c: eth0 NIC Link is Up<100 Mbps Full Duplex>
> Oct  7 00:56:22 baDibere kernel: [  194.849361] NVRM: Xid  
> (0001:00): 16, Head 00000000 Count 00003651
> Oct  7 00:56:31 baDibere kernel: [  203.849307] NVRM: Xid  
> (0001:00): 16, Head 00000000 Count 00003653
> Oct  7 00:56:36 baDibere kernel: [  208.849339] NVRM: Xid  
> (0001:00): 8, Channel 00000003
> Oct  7 00:56:41 baDibere kernel: [  213.852320] NVRM: Xid  
> (0001:00): 16, Head 00000000 Count 00003655
>
>
> The "Unable to allocate MSI interrupt" might be the immediate problem.
>
> Who belongs to MSI interrupt allocation?  PCI?  ACPI?
>
> However the driver does attempt to handle and recover from the MSI
> interrupt allocation error so perhaps that's no the cause at all.
>

I'd be curious to know if the lockup occurs when booted with pci=nomsi.

Jay
Comment 6 Erdem Artan 2009-10-07 10:02:29 UTC
I added "pci=nomsi" at the and of boot parameters in GRUB screen. But
computer again freezes when i give the command "ifconfig eth0 up".

In syslog no soft lockup seems.

syslog is in attachment.
Comment 7 Erdem Artan 2009-10-07 10:03:24 UTC
Created attachment 23298 [details]
syslog 2
Comment 8 Erdem Artan 2009-10-09 13:34:33 UTC
I tried Ubuntu and at first there was no eth0 interface. I compiled driver
and no problem.

I tried Arch Linux, there was eth0 interface but cannot get IP from dhcp or
static.

Freeze problem continues with Pardus.

Erdem Artan
Comment 9 Erdem Artan 2009-12-12 22:33:59 UTC
I tried kernel2.6.32 from testing repo of arch linux ten minutes ago. There was no error and everything is ok.

But with kernel2.6.31, there is no network interface without using acpi=off parameter.

Note You need to log in before you can comment on or make changes to this bug.