Bug 14324 - Commit a9327cac440be4d8333bba975cbbf76045096275 causes iostat output
Commit a9327cac440be4d8333bba975cbbf76045096275 causes iostat output
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Block Layer
All Linux
: P1 normal
Assigned To: Jens Axboe
:
Depends on:
Blocks: 14230
  Show dependency treegraph
 
Reported: 2009-10-04 21:46 UTC by Rafael J. Wysocki
Modified: 2009-10-05 19:23 UTC (History)
0 users

See Also:
Kernel Version: 2.6.32-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-10-04 21:46:47 UTC
Subject    : [bisected] commit: a9327cac440be4d8333bba975cbbf76045096275 causes iostat output
Submitter  : Corrado Zoccolo <czoccolo@gmail.com>
Date       : 2009-10-04 12:49
References : http://lkml.org/lkml/2009/10/4/19
Handled-By : Jens Axboe <jens.axboe@oracle.com>

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit a9327cac440be4d8333bba975cbbf76045096275
Author: Nikanth Karthikesan <knikanth@suse.de>
Date:   Fri Sep 11 09:18:54 2009 +0200

    Seperate read and write statistics of in_flight requests

    Signed-off-by: Nikanth Karthikesan <knikanth@suse.de>
    Signed-off-by: Jens Axboe <jens.axboe@oracle.com>

First-Bad-Commit : a9327cac440be4d8333bba975cbbf76045096275
Comment 1 Jens Axboe 2009-10-05 08:26:53 UTC
It's fixed, the offending commit has been reverted and -rc3 isn't affected.

Note You need to log in before you can comment on or make changes to this bug.