Bug 14298 - warning at manage.c:361 (set_irq_wake), matrix-keypad related?
Summary: warning at manage.c:361 (set_irq_wake), matrix-keypad related?
Status: CLOSED CODE_FIX
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: platform_other
URL:
Keywords:
Depends on:
Blocks: 14230
  Show dependency tree
 
Reported: 2009-10-01 22:08 UTC by Rafael J. Wysocki
Modified: 2011-01-16 12:56 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-10-01 22:08:16 UTC
Subject    : 32-rc1 aka 32-rc2: warning at manage.c:361 (set_irq_wake), matrix-keypad related?
Submitter  : Pavel Machek <pavel@ucw.cz>
Date       : 2009-09-30 20:07
References : http://marc.info/?l=linux-kernel&m=125434130703538&w=4

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2010-10-26 08:00:16 UTC
fixed by http://www.spinics.net/linux/lists/arm-kernel/msg78398.html which is
now: 
	commit dd219234d201431d0fc56a74e3a4a97ca3eb4589 
	Author: Dmitry Torokhov <dmitry.torokhov@gmail.com> 
	Date:   Thu Dec 24 22:50:23 2009 -0800

   Input: matrix-keypad - handle cases when GPIOs can't be wakeup sources

which was merged for 2.6.33-rc3, but it was not backported to 2.6.32.y.
Comment 2 Florian Mickler 2010-10-26 08:01:41 UTC
(I asked Pavel privately if it is needed for 2.6.32.y)

Note You need to log in before you can comment on or make changes to this bug.