Bug 14297 - console resume broken since ba15ab0e8d
console resume broken since ba15ab0e8d
Status: CLOSED DOCUMENTED
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: drivers_other
:
: 15032 (view as bug list)
Depends on:
Blocks: 7216 14230
  Show dependency treegraph
 
Reported: 2009-10-01 22:05 UTC by Rafael J. Wysocki
Modified: 2011-01-16 22:04 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.32-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-10-01 22:05:24 UTC
Subject    : console resume broken since ba15ab0e8de0d4439a91342ad52d55ca9e313f3d
Submitter  : Sascha Hauer <s.hauer@pengutronix.de>
Date       : 2009-09-30 15:11
References : http://marc.info/?l=linux-kernel&m=125432349404060&w=4

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit ba15ab0e8de0d4439a91342ad52d55ca9e313f3d
Author: Deepak Saxena <dsaxena@laptop.org>
Date:   Sat Sep 19 13:13:33 2009 -0700

    Set proper console speed on resume if console suspend is disabled

    Signed-off-by: Deepak Saxena <dsaxena@laptop.org>
    Signed-off-by: Alan Cox <alan@linux.intel.com>
    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
Comment 1 Rafael J. Wysocki 2009-10-02 17:27:25 UTC
On Friday 02 October 2009, Sascha Hauer wrote:
> Hi Rafael,
> 
> On Thu, Oct 01, 2009 at 09:38:46PM +0200, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.31.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=14297
> > Subject		: console resume broken since ba15ab0e8d
> > Submitter	: Sascha Hauer <s.hauer@pengutronix.de>
> > Date		: 2009-09-30 15:11 (2 days old)
> > References	: http://marc.info/?l=linux-kernel&m=125432349404060&w=4
> 
> Thanks for reporting this. Yes, the entry is still valid.
Comment 2 Rafael J. Wysocki 2010-02-01 00:15:48 UTC
First-Bad-Commit : ba15ab0e8de0d4439a91342ad52d55ca9e313f3d
Comment 3 Rafael J. Wysocki 2010-02-01 00:16:25 UTC
*** Bug 15032 has been marked as a duplicate of this bug. ***
Comment 4 Florian Mickler 2010-02-08 10:11:01 UTC
hey, this is the oldest tracked regression currently... as such (and as a bisected one, which got reported 2 times) it deserves some action... dosn't it?
Comment 5 Rafael J. Wysocki 2011-01-16 22:03:43 UTC
Well, I'd say, having looked at this issue, the problem only happens if
suspend is carried out with no_console_suspend, which isn't guaranteed
to be reliable at all.

Note You need to log in before you can comment on or make changes to this bug.