Bug 14294 - kernel BUG at drivers/ide/ide-disk.c:187
kernel BUG at drivers/ide/ide-disk.c:187
Status: CLOSED UNREPRODUCIBLE
Product: IO/Storage
Classification: Unclassified
Component: IDE
All Linux
: P1 normal
Assigned To: io_ide@kernel-bugs.osdl.org
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-10-01 21:54 UTC by Rafael J. Wysocki
Modified: 2009-11-30 20:21 UTC (History)
0 users

See Also:
Kernel Version: 2.6.31
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-10-01 21:54:26 UTC
Subject    : kernel BUG at drivers/ide/ide-disk.c:187 (2.6.31)
Submitter  : Santiago Garcia Mantinan <manty@manty.net>
Date       : 2009-09-30 11:05
References : http://marc.info/?l=linux-kernel&m=125430926311466&w=4
Handled-By : David Miller <davem@davemloft.net>
Notify-Also : Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-10-12 21:37:00 UTC
On Monday 12 October 2009, Santiago Garcia Mantinan wrote:
> Hi!
> 
> > I gave the user a debugging patch, but they reported that they
> > can no longer trigger the issue with 2.6.31.1
> > 
> > See:
> > 
> > 	http://marc.info/?l=linux-ide&m=125469615425454&w=4
> > 
> > Maybe that's enough to close this, I dunno.
> 
> I'm the user with the debugging patch, I'd say no, don't close it.
> 
> Even though on my first tests I had the computer to crash the two weekends I
> had tested, it seems that crashing on weekend was only luck and seems that
> having the bug appear is more difficult than I had thought.
> 
> So... my comments saying that 2.6.31.1 seemed ok are probably wrong (I have
> read the .1 changelog and there is an ata patch, but probably unrelated). It
> is true that I had 2.6.31.1 running for a whole week without it crashing,
> but seems that crashing it may need more time.
> 
> I'm now back to the 2.6.31 with the patch to debug it (3 days uptime) in
> order to gather more info and after I get the info from 2.6.31 I'd test
> 3.6.31.latest or even 2.6.32whatever in case you find that better.
Comment 2 Rafael J. Wysocki 2009-11-30 20:20:02 UTC
On Sunday 29 November 2009, Santiago Garcia Mantinan wrote:
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=14294
> 
> Hi!
> 
> Sorry for not answering before, I've been running 2.6.31 patched for all
> this time and the results are a bit dissapointing...
> 
> The first run was for almost a month and ended up with half a hang, I could
> read on the console that there had been an error on one of the disks, dma
> error, the keyboard was working, getty seemed to work but then login didn't
> show up when entering the username even though the disks led was flashing
> when I operated the console entering usernames and all that. This hang was
> not like the hangs I had before, don't know if it was due to the patch and
> the unknown operation arriving to the IDE disk, but the message that the
> patch was supposed to display was not displayed at all.
> 
> The second run is current run I believe, currently it has an uptime of 18
> days and not problem was showed over this time.
> 
> So... I'm afraid I'm not able to reproduce this and maybe the whole problem
> is hardware related, even though the machine had been running with 2.6.30 in
> a stable way, it is an old machine, so maybe it is not as healthy as I
> believed, and even though memtest doesn't show any errors there could be
> some dma problems or other weird things happening around :-(
> 
> So... I'd say you can close the bug and if I happen to find it again... I'll
> report it again.

Note You need to log in before you can comment on or make changes to this bug.