Bug 14266 - regression in page writeback
Summary: regression in page writeback
Status: CLOSED CODE_FIX
Alias: None
Product: Memory Management
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Andrew Morton
URL:
Keywords:
Depends on:
Blocks: 13615
  Show dependency tree
 
Reported: 2009-09-29 22:37 UTC by Rafael J. Wysocki
Modified: 2009-10-12 21:33 UTC (History)
0 users

See Also:
Kernel Version: 2.6.32-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-09-29 22:37:22 UTC
Subject    : regression in page writeback
Submitter  : Shaohua Li <shaohua.li@intel.com>
Date       : 2009-09-22 5:49
References : http://marc.info/?l=linux-kernel&m=125359858117176&w=4
Handled-By : Wu Fengguang <fengguang.wu@intel.com>
Notify-Also : Peter Zijlstra <a.p.zijlstra@chello.nl>
Notify-Also : Richard Kennedy <richard@rsk.demon.co.uk>
Notify-Also : Chris Mason <chris.mason@oracle.com>
Notify-Also : Andrew Morton <akpm@linux-foundation.org>
Notify-Also : Dave Chinner <david@fromorbit.com>
Notify-Also : Christoph Hellwig <hch@infradead.org>
Notify-Also : Theodore Tso <tytso@mit.edu>

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-09-29 22:40:21 UTC
Sorry, the regression is from 2.6.30, actually.

Caused by:

commit d7831a0bdf06b9f722b947bb0c205ff7d77cebd8
Author: Richard Kennedy <richard@rsk.demon.co.uk>
Date:   Tue Jun 30 11:41:35 2009 -0700

    mm: prevent balance_dirty_pages() from doing too much work

    Signed-off-by: Richard Kennedy <richard@rsk.demon.co.uk>
    Acked-by: Peter Zijlstra <a.p.zijlstra@chello.nl>
    Cc: Jens Axboe <jens.axboe@oracle.com>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
    Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>

First-Bad-Commit : d7831a0bdf06b9f722b947bb0c205ff7d77cebd8
Comment 2 Rafael J. Wysocki 2009-10-12 21:33:01 UTC
On Monday 12 October 2009, Shaohua Li wrote:
> On Mon, Oct 12, 2009 at 07:01:09AM +0800, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.30 and 2.6.31.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.30 and 2.6.31.  Please verify if it still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=14266
> > Subject             : regression in page writeback
> > Submitter   : Shaohua Li <shaohua.li@intel.com>
> > Date                : 2009-09-22 5:49 (20 days old)
> > References  : http://marc.info/?l=linux-kernel&m=125359858117176&w=4
> > Handled-By  : Wu Fengguang <fengguang.wu@intel.com>
> The regression is disappeared in latest git tree

Note You need to log in before you can comment on or make changes to this bug.