Bug 14261 - e1000e jumbo frames no longer work: 'Unsupported MTU setting'
e1000e jumbo frames no longer work: 'Unsupported MTU setting'
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: drivers_network@kernel-bugs.osdl.org
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-09-29 22:15 UTC by Rafael J. Wysocki
Modified: 2009-10-12 21:30 UTC (History)
0 users

See Also:
Kernel Version: 2.6.31
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-09-29 22:15:49 UTC
Subject    : 2.6.31 regression: e1000e jumbo frames no longer work: 'Unsupported MTU setting'
Submitter  : Nix <nix@esperi.org.uk>
Date       : 2009-09-26 11:16
References : http://marc.info/?l=linux-kernel&m=125396433321342&w=4
Handled-By : Alexander Duyck <alexander.duyck@gmail.com>
Patch      : http://patchwork.kernel.org/patch/50277/

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-10-12 21:30:38 UTC
On Monday 12 October 2009, David Miller wrote:
> From: "Rafael J. Wysocki" <rjw@sisk.pl>
> Date: Mon, 12 Oct 2009 01:01:08 +0200 (CEST)
> 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=14261
> > Subject		: e1000e jumbo frames no longer work: 'Unsupported MTU setting'
> > Submitter	: Nix <nix@esperi.org.uk>
> > Date		: 2009-09-26 11:16 (16 days old)
> > References	: http://marc.info/?l=linux-kernel&m=125396433321342&w=4
> > Handled-By	: Alexander Duyck <alexander.duyck@gmail.com>
> > Patch		: http://patchwork.kernel.org/patch/50277/
> 
> Fixed by:
> 
> commit a825e00c98a2ee37eb2a0ad93b352e79d2bc1593
> Author: Alexander Duyck <alexander.h.duyck@intel.com>
> Date:   Fri Oct 2 12:30:42 2009 +0000
> 
>     e1000e: swap max hw supported frame size between 82574 and 82583
>     
>     There appears to have been a mixup in the max supported jumbo frame size
>     between 82574 and 82583 which ended up disabling jumbo frames on the 82574
>     as a result.  This patch swaps the two so that this issue is resolved.
>     
>     This patch fixes http://bugzilla.kernel.org/show_bug.cgi?id=14261
>     
>     Signed-off-by: Alexander Duyck <alexander.h.duyck@intel.com>
>     Signed-off-by: Jeff Kirsher <jeffrey.t.kirsher@intel.com>
>     Signed-off-by: David S. Miller <davem@davemloft.net>

Note You need to log in before you can comment on or make changes to this bug.