Bug 14260 - T400 suspend/resume regression
T400 suspend/resume regression
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 14230
  Show dependency treegraph
 
Reported: 2009-09-29 22:12 UTC by Rafael J. Wysocki
Modified: 2009-10-03 22:55 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-09-29 22:12:01 UTC
Subject    : T400 suspend/resume regression -- bisected to a mystery merge commit
Submitter  : Theodore Tso <tytso@mit.edu>
Date       : 2009-09-26 6:57
References : http://marc.info/?l=linux-kernel&m=125394827806011&w=4
Handled-By : "Rafael J. Wysocki" <rjw@sisk.pl>

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Theodore Tso 2009-10-03 22:40:22 UTC
The problem has gone away in the latest release.  Linus posited that commit ID 89133f935 might fix the problem, and while I haven't tested to make sure that it is indeed the commit that made the problem go away, a kernel built using 2.6.32-rc1-git4 is no longer exhibiting the problem, and it was drop-dead easy to reproduce before.

Linus seems to be a little dubious about original bisected commit (75c5158f) and whether it should be reverted entirely, but for now, the problem seems to be fixed.
Comment 2 Rafael J. Wysocki 2009-10-03 22:55:12 UTC
Thanks for the update, closing.

Note You need to log in before you can comment on or make changes to this bug.