Bug 14254 - Hibernation broken by clocksource: Save mult_orig in clocksource_disable()
Hibernation broken by clocksource: Save mult_orig in clocksource_disable()
Status: CLOSED DUPLICATE of bug 14222
Product: Timers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: john stultz
:
Depends on:
Blocks: 7216 13615
  Show dependency treegraph
 
Reported: 2009-09-29 21:38 UTC by Rafael J. Wysocki
Modified: 2009-10-02 17:50 UTC (History)
0 users

See Also:
Kernel Version: 2.6.31
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-09-29 21:38:18 UTC
Subject    : Hibernation oops with 2.6.31 won't fit the screen - how to debug?
Submitter  : Ondrej Zary <linux@rainbow-software.org>
Date       : 2009-09-19 19:55
References : http://marc.info/?l=linux-kernel&m=125339012527719&w=4

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.

Bisection leads to:

commit c7121843685de2bf7f3afd3ae1d6a146010bf1fc
Author: Magnus Damm <magnus.damm@gmail.com>
Date:   Tue Jul 28 14:09:55 2009 -0700

    clocksource: Save mult_orig in clocksource_disable()

    To fix the common case where ->enable() does not set up
    mult, make sure mult_orig is saved in mult on disable.

    Also add comments to explain why we do this.

    Signed-off-by: Magnus Damm <damm@igel.co.jp>
    Cc: johnstul@us.ibm.com
    Cc: lethal@linux-sh.org
    Cc: akpm@linux-foundation.org
    LKML-Reference: <20090618152432.10136.9932.sendpatchset@rx1.opensource.se>
    Signed-off-by: Thomas Gleixner <tglx@linutronix.de>

First-Bad-Commit : c7121843685de2bf7f3afd3ae1d6a146010bf1fc
Comment 1 john stultz 2009-09-29 21:53:49 UTC
This looks identical to http://bugzilla.kernel.org/show_bug.cgi?id=14222

Dupe?
Comment 2 Rafael J. Wysocki 2009-10-02 17:50:10 UTC
Yeah.

*** This bug has been marked as a duplicate of bug 14222 ***

Note You need to log in before you can comment on or make changes to this bug.