Bug 14252 - WARNING: at include/linux/skbuff.h:1382 w/ e1000
WARNING: at include/linux/skbuff.h:1382 w/ e1000
Status: CLOSED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: drivers_network@kernel-bugs.osdl.org
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-09-29 21:25 UTC by Rafael J. Wysocki
Modified: 2010-12-21 10:13 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.31
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-09-29 21:25:41 UTC
Subject    : What about this message (2.6.31) ?
Submitter  : Stephan von Krawczynski <skraw@ithnet.com>
Date       : 2009-09-20 11:26
References : http://marc.info/?l=linux-kernel&m=125344599006033&w=4

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-11-23 19:32:09 UTC
On Monday 23 November 2009, Tantilov, Emil S wrote:
> David Miller wrote:
> > From: "Rafael J. Wysocki" <rjw@sisk.pl>
> > Date: Tue, 17 Nov 2009 00:01:18 +0100 (CET)
> > 
> >> This message has been generated automatically as a part of a report
> >> of regressions introduced between 2.6.30 and 2.6.31.
> >> 
> >> The following bug entry is on the current list of known regressions
> >> introduced between 2.6.30 and 2.6.31.  Please verify if it still
> >> should be listed and let me know (either way).
> >> 
> >> 
> >> Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=14252
> >> Subject		: WARNING: at include/linux/skbuff.h:1382 w/ e1000
> >> Submitter	: Stephan von Krawczynski <skraw@ithnet.com>
> >> Date		: 2009-09-20 11:26 (58 days old)
> >> References	: http://marc.info/?l=linux-kernel&m=125344599006033&w=4
> > 
> > Please CC: netdev when reporting networking problems, thank you.
> > 
> > Intel folks can you please take a look at this?  Thanks.
> 
> I have not been able to reproduce this issue so far. I don't have the exact same HW, but I tested on stock 2.6.31 with 82541 based NIC. More than 3 days now of stress without a problem.
> 
> If the reporter can provide some additional information that may be of help:
> 1. cat /proc/interrupts
> 2. ethtool -i ethX (where ethX is the interface that is causing the problem
> 3. lspci -vvv
> 4. ethtool -e ethX
> 5. specific settings that may deviate from the default configuration (like MTU)
> 6. type of traffic that is causing the issue.
> 
> Thanks,
> Emil--
Comment 2 Florian Mickler 2010-12-17 21:00:45 UTC
Stephan, is this still a problem?
Comment 3 Stephan von Krawczynski 2010-12-20 16:51:33 UTC
On Fri, 17 Dec 2010 21:00:49 GMT
bugzilla-daemon@bugzilla.kernel.org wrote:

> https://bugzilla.kernel.org/show_bug.cgi?id=14252
> 
> 
> Florian Mickler <florian@mickler.org> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |florian@mickler.org,
>                    |                            |skraw@ithnet.com
> 
> 
> 
> 
> --- Comment #2 from Florian Mickler <florian@mickler.org>  2010-12-17 21:00:45 ---
> Stephan, is this still a problem?
> 
> -- 
> Configure bugmail: https://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
> 

We have not seen the problem for some time now.
Comment 4 Florian Mickler 2010-12-21 10:13:25 UTC
I'm closing this as 'unreproducible'. If you know what commit fixed it, we can change that to 'code_fix'. If it happens again, we reopen. 

Thanks for the update,
Flo

Note You need to log in before you can comment on or make changes to this bug.