Bug 14251 - 2.6.31: no login prompt
2.6.31: no login prompt
Status: CLOSED DOCUMENTED
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-09-29 21:21 UTC by Rafael J. Wysocki
Modified: 2009-10-07 19:51 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.31
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-09-29 21:21:43 UTC
Subject    : 2.6.31: no login prompt
Submitter  : "Frédéric L. W. Meunier" <fredlwm@gmail.com>
Date       : 2009-09-19 22:43
References : http://marc.info/?l=linux-kernel&m=125340020804711&w=4

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Frédéric L. W. Meunier 2009-10-01 23:18:56 UTC
Great, Rafael. There's also http://marc.info/?l=linux-kernel&m=125390802701579&w=2 about it.
Comment 2 Frédéric L. W. Meunier 2009-10-07 04:40:27 UTC
It really looks like something is broken in the creation of files under /dev.

When I finally rebooted, now with 2.6.31.2, vc/4 was working. But all other configured consoles in /etc/inittab (tty1 to tty3) didn't.

ttyS1 also points to tts/1, which doesn't exist. Under /dev/tts there are 0, 2 and 3. When I boot, dmesg shows

serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A

In the udev rules:

# tty devices
KERNEL=="console", NAME="%k", GROUP="tty", MODE="0600"
KERNEL=="tty", NAME="%k", GROUP="tty", MODE="0666"
KERNEL=="tty[0-9]*", NAME="vc/%n", SYMLINK="%k", GROUP="tty", MODE="0666"
KERNEL=="ttyS[0-7]*", NAME="tts/%n", SYMLINK="%k", GROUP="uucp", MODE="0660"

# vc devices
KERNEL=="vcs", NAME="vcc/0", GROUP="tty", SYMLINK="%k"
KERNEL=="vcs[0-9]*", NAME="vcc/%n", GROUP="tty", SYMLINK="%k"
KERNEL=="vcsa", NAME="vcc/a0", GROUP="tty", SYMLINK="%k"
KERNEL=="vcsa[0-9]*", NAME="vcc/a%n", GROUP="tty", SYMLINK="%k"
Comment 3 Frédéric L. W. Meunier 2009-10-07 14:27:23 UTC
It isn't a regression. It's the "devfs" naming removal in 2.6.31. I was using the old names everywhere.

You can close this.
Comment 4 Rafael J. Wysocki 2009-10-07 19:51:49 UTC
OK, closing.

Note You need to log in before you can comment on or make changes to this bug.