Bug 14234 - The PC speaker console beep no longer happens
The PC speaker console beep no longer happens
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Console/Framebuffers
All Linux
: P1 normal
Assigned To: James Simmons
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-09-26 13:02 UTC by Allan Duncan
Modified: 2010-11-12 20:43 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.30 2.6.30.6 2.6.31
Tree: Mainline
Regression: Yes


Attachments

Description Allan Duncan 2009-09-26 13:02:42 UTC
I'm rather attached to the console beep on the traditional case speaker when using tab-complete to alert me to errors I have made.
All the kernels later than 2.6.29.x do not make a sound despite the presence of the pcspkr module.

I have seen mention of this on the fedora bugzilla, but I have established that a pure kernel.org version running at level 3 also fails.
Comment 1 Allan Duncan 2009-10-13 10:28:02 UTC
Additional:
This happened on an x86_64, whereas running 2.6.30 on an Athlon K7 doesn't trigger the bug.  When time permits I will create a 32bit install on the Phenom mboard.
Comment 2 James Simmons 2010-02-16 16:38:41 UTC
Have you noticed this problem still?
Comment 3 Allan Duncan 2010-02-19 01:14:06 UTC
I just tried 2.6.33-rc8 on x86_64 and at least at run level 3 the beep is back.  At this instant, due to a lack of mouse and keyboard input to X with this kernel, I can't confirm that it works with level 5, but since it appears to use drivers/char/vt.c for terminal emulation I presume so.

Looking at the diffs 2.6.29 to 2.6.30 there didn't seem to be any change of consequence, but I did notice that there exists flags SND_BELL and SND_TONE that feature in drivers/input/misc/pcspkr.c and drivers/char/keyboard.c, but I was unable to find where these are actually set.  Changing that setting is all that is needed to create the behaviour I see.

I will dig further as time permits, but if the beep is back, I'm less motivated.  How to alter this low level behaviour needs to be up front though, there are good arguments for the user to choose the applicable expression of ^G.
Comment 4 Florian Mickler 2010-11-12 20:43:35 UTC
I'm closing this as fixed then.

Note You need to log in before you can comment on or make changes to this bug.