Bug 14196 - Wireless cards cannot associate to APs (wpa_supplicant keeps doing scans)
Wireless cards cannot associate to APs (wpa_supplicant keeps doing scans)
Status: CLOSED CODE_FIX
Product: Networking
Classification: Unclassified
Component: Wireless
All Linux
: P1 normal
Assigned To: networking_wireless@kernel-bugs.osdl.org
:
: 14202 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-20 16:30 UTC by Fabio Scaccabarozzi
Modified: 2009-09-30 15:56 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32-rc0
Tree: Mainline
Regression: No


Attachments
dmesg non-working output (8.90 KB, application/octet-stream)
2009-09-20 16:30 UTC, Fabio Scaccabarozzi
Details

Description Fabio Scaccabarozzi 2009-09-20 16:30:07 UTC
Created attachment 23121 [details]
dmesg non-working output

I'm running b43 driver on amd64, I upgraded to the latest git after running 2.6.31-rc9 for some time and found connection not working. Attached there's a log of the b43 driver. Running iwevent showed that it kept cycling through scans but never associating.
Initially I thought it was a problem with b43 itself but trying to upgrade also on the laptop (ath5k on x86) showed the very same problem.
I bisected the commits and found the culprit:
cfg80211: fix SME connect (bbac31f4c0339f6c51afbd0edfb4959df9b53fa9)
Reverting the commit fixes the issues, connection works again.
Comment 1 John W. Linville 2009-09-29 18:32:50 UTC
This should be fixed in 2.6.32-rc1.
Comment 2 John W. Linville 2009-09-29 18:36:41 UTC
*** Bug 14202 has been marked as a duplicate of this bug. ***
Comment 3 Fabio Scaccabarozzi 2009-09-30 15:56:44 UTC
Yep, fixed. Thanks.

Note You need to log in before you can comment on or make changes to this bug.