Bug 14164 - "Unknown boot option" warning message should not be printed for options which will be passed to kernel modules
"Unknown boot option" warning message should not be printed for options which...
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Rusty Russell
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-11 16:28 UTC by Adam Williamson
Modified: 2012-06-13 16:57 UTC (History)
5 users (show)

See Also:
Kernel Version: all
Tree: Mainline
Regression: No


Attachments

Description Adam Williamson 2009-09-11 16:28:54 UTC
When passing a kernel parameter of the type:

radeon.modeset=0

the kernel will throw a warning message that says "Unknown boot option 'radeon.modeset=0'. Ignoring..." However, the parameter is not ignored, it is passed to (and parsed by) the radeon module.

We (Fedora QA/BugZappers) find people are often confused or worried by this message when we ask them to use such a parameter, and worry that it is not being applied correctly. The kernel should not print this warning/error message when the parameter is of a format that will cause it to be passed to a kernel module.
Comment 1 Rusty Russell 2009-09-22 02:50:17 UTC
Is this because modern modprobe is scraping these options from /proc/cmdline?  If so, yes, we should suppress those messages altogether.

CC'd Jon, he'd know.
Comment 2 Adam Williamson 2009-09-22 04:51:52 UTC
I don't know how it's implemented, exactly, that may well be how it works. I just know that you can pass any module parameter as a kernel command line parameter in that format (modulename.moduleparameter=value) and it gets passed on somehow.
Comment 3 Adam Williamson 2009-11-26 17:43:30 UTC
ping? this still regularly causes confusion for users when we're trying to debug various issues, see https://bugzilla.redhat.com/show_bug.cgi?id=538840#c3 for a recent example: it's a 'cosmetic' bug but with unfortunate effects.
Comment 4 Jon Masters 2010-03-21 12:03:01 UTC
Yea, exactly that's what happens. Modprobe pulls out those arguments and processes them.

I don't know why I missed this bug, but that should be fixed now. I even have daily reminders setup and should get CC'd on every module issue from now on.

Note You need to log in before you can comment on or make changes to this bug.