Bug 14161 - ACPI conflict with i2c-driver (i2c-viapro)
Summary: ACPI conflict with i2c-driver (i2c-viapro)
Status: CLOSED DUPLICATE of bug 13939
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-11 13:00 UTC by miniwill
Modified: 2009-11-06 06:46 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.31
Tree: Mainline
Regression: Yes


Attachments

Description miniwill 2009-09-11 13:00:37 UTC
Since the kernel 2.6.31-rc2 the i2c-viapro module is broken due to ACPI.

modprobe i2c-viapro
dmesg :
[  284.901274] ACPI: I/O resource vt596_smbus [0x500-0x507] conflicts with ACPI region SMB1 [0x505-0x506]
[  284.901286] ACPI: Device needs an ACPI driver
[  284.901302] vt596_smbus: probe of 0000:00:11.0 failed with error -16

I think the problem is due to ACPI. In fact, code of the i2c-viapro didn't change between 2.6.31-rc1 and 2.6.31-rc2 and it worked in 2.6.31-rc1 but not in all the more recent others.

I'm a simple user, not a developer but i need to use the i2c/smbus of my machine.

Best regards.

Miniwill
Comment 1 Zhang Rui 2009-09-14 05:26:45 UTC

*** This bug has been marked as a duplicate of bug 13939 ***

Note You need to log in before you can comment on or make changes to this bug.