Bug 14151 - VIA82xx volume regression
VIA82xx volume regression
Status: CLOSED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 blocking
Assigned To: Jaroslav Kysela
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-10 10:25 UTC by Heikki Orsila
Modified: 2012-06-13 16:54 UTC (History)
5 users (show)

See Also:
Kernel Version: 7135a71b19be1faf48b7148d77844d03bc0717d6 (git HEAD after 2.6.31-rc9)
Tree: Mainline
Regression: Yes


Attachments

Description Heikki Orsila 2009-09-10 10:25:49 UTC
commit b452e08e73c0e3dbb0be82130217be4b7084299e breaks VIA82xx sound on my system. Channels are muted, I get no sound. I bisected the bug down to that commit.

git revert b452e08e73 fixed the problem on top of latest git HEAD (7135a71b19be1faf48b7148d77844d03bc0717d6).

I should have upgraded the kernel months ago to see this bug :-) It is 100% reproducible.

My setup is Debian testing:

Linux jsap 2.6.31-rc9-00016-g54cacf1 #30 Thu Sep 10 13:08:36 EEST 2009 x86_64 GNU/Linux
 
Gnu C                  4.2.4
Gnu make               3.81
binutils               2.19.51.20090723
util-linux             scripts/ver_linux: line 23: fdformat: command not found
mount                  support
module-init-tools      found
Linux C Library        2.9
Dynamic linker (ldd)   2.9
Procps                 3.2.8
Console-tools          0.2.3
Sh-utils               7.4
udev                   125

00:00.0 Host bridge: VIA Technologies, Inc. VT8385 [K8T800 AGP] Host Bridge (rev 01)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
00:07.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306 Fire II IEEE 1394 OHCI Link Layer Controller (rev 80)
00:08.0 RAID bus controller: Promise Technology, Inc. PDC20378 (FastTrak 378/SATA 378) (rev 02)
00:0a.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
00:0c.0 Ethernet controller: Intel Corporation 82541GI Gigabit Ethernet Controller
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400/G450 (rev 85)
Comment 1 Takashi Iwai 2009-09-11 06:12:05 UTC
It fixes the wrong volume ranges in the driver side, but unfortunately, your system still remembers the old bogus values and tries to restore them.  This resulted in the silence.  So, it's a mixer setup issue.

Don't revert the commit but just raise "DXS Playback Volume" elements in your mixer to 100%.
Comment 2 Heikki Orsila 2009-09-11 12:30:56 UTC
(In reply to comment #1)
> It fixes the wrong volume ranges in the driver side, but unfortunately, your
> system still remembers the old bogus values and tries to restore them.  This
> resulted in the silence.  So, it's a mixer setup issue.

How will people know how to do that? The old system just worked for them (set master and pcm).

> Don't revert the commit but just raise "DXS Playback Volume" elements in your
> mixer to 100%.

I thought regressions were not allowed in the kernel.
Comment 3 Takashi Iwai 2009-09-11 15:45:58 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > It fixes the wrong volume ranges in the driver side, but unfortunately, your
> > system still remembers the old bogus values and tries to restore them.  This
> > resulted in the silence.  So, it's a mixer setup issue.
> 
> How will people know how to do that? The old system just worked for them (set
> master and pcm).

Just because the old system uses the invalid values that the driver accepted wrongly.
 
> > Don't revert the commit but just raise "DXS Playback Volume" elements in your
> > mixer to 100%.
> 
> I thought regressions were not allowed in the kernel.

This is no regression but the fix of a long-standing bug.
Comment 4 Andrew Morton 2009-09-11 21:37:00 UTC
Well his system as a whole _did_ regress.  Due to kernel changes.

It would have been better to have arranged for the kernel to recognise the old values and do something useful with them.  Make it a back-compatible change.
Comment 5 Heikki Orsila 2009-09-12 00:27:12 UTC
(In reply to comment #4)
> Well his system as a whole _did_ regress.  Due to kernel changes.
> 
> It would have been better to have arranged for the kernel to recognise the old
> values and do something useful with them.  Make it a back-compatible change.

I tried to make sound work after the "fix", and using mixer I could not make it work. I know I'm not a "basic" user that is not aware of technical issues. Therefore, I think, it is very reasonable to revert this change. Many people must have run into great difficulties to make VIA82xx sound work again. Please revert this change. It is _definite_ regression, since it worked for _4_ years before this "fix".
Comment 6 Andrew Pimlott 2009-10-05 16:22:28 UTC
Hi.  I'm experiencing symptoms similar to this bug, but for me, raising the DXS mixer levels doesn't solve it.  If I raise the first DXS level all the way and max out the volume on my speakers, it's audible but hardly reasonable.  None of the other DXS levels have any effect.  (Neither does the Master level, but I think I read that's expected.)

In 2.6.26, with my speakers at a normal setting, sound plays at reasonable volume.  I can try other kernels later, but any hints?
Comment 7 Andrew Pimlott 2009-10-20 05:23:59 UTC
Forget about my comment.  There is another new mixer level, "Front", that was not in 2.6.26 and was set to 0 when I booted 2.6.30.  I just had to turn it up (I have plain Jane stereo speakers plugged in to line out).

There really should be better defaults for new mixer levels, either in the module or in alsactl.  This was really frustrating.

Note You need to log in before you can comment on or make changes to this bug.