Bug 14120 - usb devices not power off during suspend-to-ram
usb devices not power off during suspend-to-ram
Status: CLOSED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2009-09-04 15:21 UTC by Ritesh Raj Sarraf
Modified: 2012-06-13 16:44 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.30
Tree: Mainline
Regression: No


Attachments
config (104.30 KB, text/plain)
2009-09-04 15:21 UTC, Ritesh Raj Sarraf
Details

Description Ritesh Raj Sarraf 2009-09-04 15:21:54 UTC
Created attachment 23010 [details]
config

I suspend my laptop to RAM. While it is STRed, if I plugin a USB device, the device can still draw power.
In my case, I have a USB cooler pad for the laptop. And even if the laptop is STRed, the USB Cooler pad's fans still run.
This shows that USB devices are still drawing power even if the laptop is suspended.

Is it expected behavior ?
I'm also not sure if this is a regression.

Kernel 2.6.30
Distrib: Debian
Machine: IBM T43
Comment 1 Rafael J. Wysocki 2009-09-04 15:28:45 UTC
This really is a question about USB drivers, so reassigning.
Comment 2 Ritesh Raj Sarraf 2009-09-07 15:41:23 UTC
More Info:

On a freshly booted box, when you suspend the usb devices are not drawing power.
Once you resume and suspend again, the usb devices will be drawing power. So looks like after the first suspend, further suspends for the usb devices fail.

Following is the relevant dmesg log:

[19183.325328] hdaps: initial mode latch is 0x01                                                 
[19183.325386] hdaps: setting ec_rate=250, filter_order=2                                        
[19183.325631] pm_op(): usb_dev_resume+0x0/0xa [usbcore] returns -19                             
[19183.325634] PM: Device 2-1 failed to resume: error -19                                        
[19183.325658] pm_op(): usb_dev_resume+0x0/0xa [usbcore] returns -19                             
[19183.325660] PM: Device 2-1.1 failed to resume: error -19                                      
[19183.325686] pm_op(): usb_dev_resume+0x0/0xa [usbcore] returns -19                             
[19183.325688] PM: Device 2-1.3 failed to resume: error -19                                      
[19183.325786] Restarting tasks ... <3>hub 1-0:1.0: over-current change on port 3                
[19183.368885] done.                                                                             
[19183.432040] hub 1-0:1.0: over-current change on port 4                                        
[19183.536045] usb 2-1: USB disconnect, address 5
[19183.536048] usb 2-1.1: USB disconnect, address 6
[19183.536469] usb 2-1.3: USB disconnect, address 7
[19183.536816] hub 3-0:1.0: over-current change on port 1
[19183.640096] hub 3-0:1.0: over-current change on port 2
[19186.276732] [drm] Num pipes: 1
[19194.172162] tg3 0000:02:00.0: PME# enabled
Comment 3 Rafael J. Wysocki 2011-01-16 22:00:02 UTC
Is the issue still present in 2.6.37?

Note You need to log in before you can comment on or make changes to this bug.