Bug 14090 - WARNING: at fs/notify/inotify/inotify_user.c:394
WARNING: at fs/notify/inotify/inotify_user.c:394
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: fs_other
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-08-30 15:21 UTC by Joerg Platte
Modified: 2010-04-08 14:51 UTC (History)
7 users (show)

See Also:
Kernel Version: 2.6.31-rc8
Tree: Mainline
Regression: Yes


Attachments

Description Joerg Platte 2009-08-30 15:21:54 UTC
Hi Eric,

here is the bug report.

------------[ cut here ]------------
WARNING: at fs/notify/inotify/inotify_user.c:394
inotify_remove_from_idr+0x47/0x8d()
Hardware name: 2373G1G
Modules linked in: pata_pcmcia snd_intel8x0m omfs jfs xfs reiserfs hfs hfsplus
isofs udf crc_itu_t sch_tbf nls_iso8859_1 nls_cp850 vfat fat usb_storage
usb_libusual nfsd lockd nfs_acl auth_rpcgss sunrpc exportfs radeon drm bridge
stp llc bnep sco rfcomm l2cap bluetooth ipt_MASQUERADE iptable_nat nf_nat
nf_conntrack_ipv4 nf_defrag_ipv4 xt_state ipt_REJECT ipt_LOG xt_limit xt_tcpudp
xt_mac xt_multiport iptable_filter iptable_mangle ip_tables x_tables vboxdrv
nf_conntrack_ftp nf_conntrack binfmt_misc af_packet cpufreq_powersave nsc_ircc
cpufreq_stats cpufreq_userspace autofs4 fuse nls_utf8 ntfs ext2
deadline_iosched as_iosched ircomm_tty ircomm tun acpi_cpufreq joydev
snd_intel8x0 snd_ac97_codec ac97_bus snd_pcm_oss snd_mixer_oss snd_pcm
snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer
snd_seq_device irtty_sir yenta_socket ipw2200 rsrc_nonstatic sir_dev
thinkpad_acpi snd pcmcia rfkill dvb_usb_cinergyT2 dvb_usb libipw led_class
psmouse rtc_cmos irda dvb_core rtc_core lib80211 soundcore ac 8250_pci
pcmcia_core nvram 8250_pnp serio_raw i2c_i801 crc_ccitt battery rtc_lib
parport_pc snd_page_alloc rng_core 8250 processor parport pcspkr serial_core
button evdev ext3 jbd mbcache usbhid hid sg sd_mod sr_mod cdrom ata_generic
pata_acpi ata_piix uhci_hcd libata ehci_hcd e1000 intel_agp usbcore nls_base
scsi_mod agpgart video output thermal fan unix cpufreq_conservative
cpufreq_ondemand freq_table radeonfb fb_ddc backlight i2c_algo_bit cfbcopyarea
i2c_core cfbimgblt cfbfillrect fbcon tileblit font bitblit softcursor fb [last
unloaded: snd_intel8x0m]
Pid: 7534, comm: digikam Tainted: G        W  2.6.31-rc8 #1
Call Trace:
 [<c01254e1>] warn_slowpath_common+0x60/0x90
 [<c012551e>] warn_slowpath_null+0xd/0x10
 [<c01b3be9>] inotify_remove_from_idr+0x47/0x8d
 [<c01b40b8>] inotify_ignored_and_remove_idr+0x74/0x88
 [<c01b3674>] inotify_freeing_mark+0x8/0xa
 [<c01b2382>] fsnotify_destroy_mark_by_entry+0x119/0x138
 [<c01b3b6d>] sys_inotify_rm_watch+0x7e/0xa2
 [<c01028f4>] sysenter_do_call+0x12/0x26
---[ end trace 4eaa2a86a8e2da24 ]---

and another trace from today:

Aug 30 08:40:49 ibm kernel: ------------[ cut here ]------------
Aug 30 08:40:49 ibm kernel: WARNING: at fs/notify/inotify/inotify_fsnotify.c:129 idr_callback+0x2d/0x51()
Aug 30 08:40:49 ibm kernel: Hardware name: 2373G1G
Aug 30 08:40:49 ibm kernel: inotify closing but id=0 for entry=f1a20770 in group=f353f280 still in idr.  Probably leaking memory
Aug 30 08:40:49 ibm kernel: Modules linked in: pata_pcmcia omfs jfs xfs reiserfs hfs hfsplus isofs udf crc_itu_t sch_tbf nls_iso8859_1 nls_cp850 vfat fat usb_storage usb_libusual nfsd lockd nfs_acl auth_rpcgss sunrpc exportfs radeon drm bridge stp llc bnep sco rfcomm l2cap bluetooth ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state ipt_REJECT ipt_LOG xt_limit xt_tcpudp xt_mac xt_multiport iptable_filter iptable_mangle ip_tables x_tables vboxdrv nf_conntrack_ftp nf_conntrack binfmt_misc af_packet cpufreq_powersave nsc_ircc cpufreq_stats cpufreq_userspace autofs4 fuse nls_utf8 ntfs ext2 deadline_iosched as_iosched ircomm_tty ircomm tun acpi_cpufreq joydev snd_intel8x0 snd_ac97_codec ac97_bus snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device irtty_sir yenta_socket ipw2200 rsrc_nonstatic sir_dev thinkpad_acpi snd pcmcia rfkill dvb_usb_cinergyT2 dvb_usb libipw led_class psmouse rtc_cmos irda dvb_core rtc_core lib802
Aug 30 08:40:49 ibm kernel: 1 soundcore ac 8250_pci pcmcia_core nvram 8250_pnp serio_raw i2c_i801 crc_ccitt battery rtc_lib parport_pc snd_page_alloc rng_core 8250 processor parport pcspkr serial_core button evdev ext3 jbd mbcache usbhid hid sg sd_mod sr_mod cdrom ata_generic pata_acpi ata_piix uhci_hcd libata ehci_hcd e1000 intel_agp usbcore nls_base scsi_mod agpgart video output thermal fan unix cpufreq_conservative cpufreq_ondemand freq_table radeonfb fb_ddc backlight i2c_algo_bit cfbcopyarea i2c_core cfbimgblt cfbfillrect fbcon tileblit font bitblit softcursor fb [last unloaded: snd_intel8x0m]
Aug 30 08:40:49 ibm kernel: Pid: 16142, comm: digikam Tainted: G        W  2.6.31-rc8 #1
Aug 30 08:40:49 ibm kernel: Call Trace:
Aug 30 08:40:49 ibm kernel:  [<c01254e1>] warn_slowpath_common+0x60/0x90
Aug 30 08:40:49 ibm kernel:  [<c0125545>] warn_slowpath_fmt+0x24/0x27
Aug 30 08:40:49 ibm kernel:  [<c01b36c9>] idr_callback+0x2d/0x51
Aug 30 08:40:49 ibm kernel:  [<c01f630d>] idr_for_each+0x5e/0x99
Aug 30 08:40:49 ibm kernel:  [<c01b369c>] ? idr_callback+0x0/0x51
Aug 30 08:40:49 ibm kernel:  [<c01b1b97>] ? fsnotify_put_event+0x44/0x47
Aug 30 08:40:49 ibm kernel:  [<c01b368b>] inotify_free_group_priv+0x15/0x26
Aug 30 08:40:49 ibm kernel:  [<c01b1cb9>] fsnotify_final_destroy_group+0x19/0x23
Aug 30 08:40:49 ibm kernel:  [<c01b1d74>] fsnotify_put_group+0x71/0x74
Aug 30 08:40:49 ibm kernel:  [<c01b384a>] inotify_release+0x19/0x25
Aug 30 08:40:49 ibm kernel:  [<c018ec03>] __fput+0xca/0x182
Aug 30 08:40:49 ibm kernel:  [<c018ecd3>] fput+0x18/0x1a
Aug 30 08:40:49 ibm kernel:  [<c018c1fa>] filp_close+0x51/0x5b
Aug 30 08:40:49 ibm kernel:  [<c01269b8>] put_files_struct+0x67/0xa9
Aug 30 08:40:49 ibm kernel:  [<c0126a33>] exit_files+0x39/0x3c
Aug 30 08:40:49 ibm kernel:  [<c0127fdf>] do_exit+0x19c/0x5ae
Aug 30 08:40:49 ibm kernel:  [<c012e39b>] ? recalc_sigpending+0xd/0x30
Aug 30 08:40:49 ibm kernel:  [<c01309c4>] ? dequeue_signal+0x9d/0x108
Aug 30 08:40:49 ibm kernel:  [<c0128453>] do_group_exit+0x62/0x88
Aug 30 08:40:49 ibm kernel:  [<c0130f7b>] get_signal_to_deliver+0x368/0x38d
Aug 30 08:40:49 ibm kernel:  [<c0101dd0>] do_notify_resume+0x75/0x6af
Aug 30 08:40:49 ibm kernel:  [<c01181df>] ? ___pte_free_tlb+0x35/0x38
Aug 30 08:40:49 ibm kernel:  [<c017b05b>] ? free_pgd_range+0x147/0x164
Aug 30 08:40:49 ibm kernel:  [<c017b0f6>] ? free_pgtables+0x7e/0x94
Aug 30 08:40:49 ibm kernel:  [<c017c53d>] ? unmap_region+0xc8/0x10c
Aug 30 08:40:49 ibm kernel:  [<c0144463>] ? sys_futex+0xe9/0xff
Aug 30 08:40:49 ibm kernel:  [<c0102a06>] work_notifysig+0x13/0x19
Aug 30 08:40:49 ibm kernel: ---[ end trace 4eaa2a86a8e2da25 ]---



Additionally, I'm getting this warning while booting the machine. I's a known BIOS bug, not sure, if it may cause the warnings above:
------------[ cut here ]------------
WARNING: at arch/x86/kernel/apic/apic.c:247 native_apic_write_dummy+0x2d/0x39()
Hardware name: 2373G1G
Modules linked in:
Pid: 0, comm: swapper Not tainted 2.6.31-rc8 #1
Call Trace:
 [<c01254e1>] warn_slowpath_common+0x60/0x90
 [<c012551e>] warn_slowpath_null+0xd/0x10
 [<c0110ac9>] native_apic_write_dummy+0x2d/0x39
 [<c010ccfa>] intel_init_thermal+0xb6/0x144
 [<c010c53b>] ? mce_init+0x33/0xb0
 [<c010cb73>] mce_intel_feature_init+0xb/0x4c
 [<c040c9ec>] mcheck_init+0x205/0x28e
 [<c040b59f>] identify_cpu+0x30b/0x31b
 [<c0152421>] ? delayacct_init+0x42/0x49
 [<c03ec727>] identify_boot_cpu+0xd/0x23
 [<c03ec773>] check_bugs+0xb/0xd4
 [<c0152421>] ? delayacct_init+0x42/0x49
 [<c03e66b3>] start_kernel+0x27b/0x28a
 [<c03e6065>] __init_begin+0x65/0x6a
---[ end trace 4eaa2a86a8e2da22 ]---
Comment 1 Eric Paris 2009-08-31 17:41:47 UTC
After the backtrace: "inotify closing but id=0 for entry=f1a20770 in
group=f353f280 still in idr.  Probably leaking memory" do you see another line of output you can't really identify?  Should be something like:

"entry->group=%p inode=%p wd=%d\n"
Comment 2 Joerg Platte 2009-08-31 17:48:18 UTC
Yes, there was this line after a new backtrace from today. The same line was there after the backtrace from yesterday. I'm switching back to 2.6.30.5 for now, since udev seems to have problems with the -rc8 kernel as well, it segfaults after unplugging USB sticks...

Aug 31 10:37:06 ibm kernel: ------------[ cut here ]------------
Aug 31 10:37:06 ibm kernel: WARNING: at fs/notify/inotify/inotify_fsnotify.c:129 idr_callback+0x2d/0x51()
Aug 31 10:37:06 ibm kernel: Hardware name: 2373G1G
Aug 31 10:37:06 ibm kernel: inotify closing but id=0 for entry=f657fea8 in group=f3ff4600 still in idr.  Probably leaking memory
Aug 31 10:37:06 ibm kernel: Modules linked in: nfs fscache usb_storage usb_libusual nls_iso8859_1 nls_cp850 vfat fat usbhid hid dvb_usb_cinergyT2 dvb_usb dvb_core pata_pcmcia nfsd lockd nfs_acl auth_rpcgss sunrpc exportfs radeon drm bridge stp llc bnep sco l2cap bluetooth ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state ipt_REJECT ipt_LOG xt_limit xt_tcpudp xt_mac xt_multiport iptable_filter iptable_mangle ip_tables x_tables nf_conntrack_ftp vboxdrv nf_conntrack binfmt_misc af_packet cpufreq_powersave cpufreq_stats nsc_ircc cpufreq_userspace autofs4 fuse nls_utf8 ntfs ext2 deadline_iosched as_iosched ircomm_tty ircomm tun acpi_cpufreq snd_intel8x0 joydev snd_ac97_codec snd_pcm_oss ac97_bus snd_mixer_oss snd_pcm snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event thinkpad_acpi snd_seq yenta_socket rsrc_nonstatic irtty_sir pcmcia snd_timer ipw2200 sir_dev psmouse pcmcia_core rfkill snd_seq_device libipw snd lib80211 led_class i2c_i801 evdev rtc_cmos irda 8250_pnp rng_core serio_r
Aug 31 10:37:06 ibm kernel: w rtc_core 8250_pci rtc_lib 8250 soundcore ac nvram parport_pc crc_ccitt serial_core parport snd_page_alloc battery button processor ext3 jbd mbcache sg sd_mod sr_mod cdrom ata_generic pata_acpi ata_piix uhci_hcd libata e1000 intel_agp video output ehci_hcd scsi_mod usbcore nls_base agpgart thermal fan unix cpufreq_conservative cpufreq_ondemand freq_table radeonfb fb_ddc backlight i2c_algo_bit cfbcopyarea i2c_core cfbimgblt cfbfillrect fbcon tileblit font bitblit softcursor fb [last unloaded: snd_intel8x0m]
Aug 31 10:37:06 ibm kernel: Pid: 27626, comm: digikam Tainted: G        W  2.6.31-rc8 #1
Aug 31 10:37:06 ibm kernel: Call Trace:
Aug 31 10:37:06 ibm kernel:  [<c01254e1>] warn_slowpath_common+0x60/0x90
Aug 31 10:37:06 ibm kernel:  [<c0125545>] warn_slowpath_fmt+0x24/0x27
Aug 31 10:37:06 ibm kernel:  [<c01b36c9>] idr_callback+0x2d/0x51
Aug 31 10:37:06 ibm kernel:  [<c01f6339>] idr_for_each+0x5e/0x99
Aug 31 10:37:06 ibm kernel:  [<c01b369c>] ? idr_callback+0x0/0x51
Aug 31 10:37:06 ibm kernel:  [<c01b1b97>] ? fsnotify_put_event+0x44/0x47
Aug 31 10:37:06 ibm kernel:  [<c01b368b>] inotify_free_group_priv+0x15/0x26
Aug 31 10:37:06 ibm kernel:  [<c01b1cb9>] fsnotify_final_destroy_group+0x19/0x23
Aug 31 10:37:06 ibm kernel:  [<c01b1d74>] fsnotify_put_group+0x71/0x74
Aug 31 10:37:06 ibm kernel:  [<c01b384a>] inotify_release+0x19/0x25
Aug 31 10:37:06 ibm kernel:  [<c018ec03>] __fput+0xca/0x182
Aug 31 10:37:06 ibm kernel:  [<c018ecd3>] fput+0x18/0x1a
Aug 31 10:37:06 ibm kernel:  [<c018c1fa>] filp_close+0x51/0x5b
Aug 31 10:37:06 ibm kernel:  [<c01269b8>] put_files_struct+0x67/0xa9
Aug 31 10:37:06 ibm kernel:  [<c0126a33>] exit_files+0x39/0x3c
Aug 31 10:37:06 ibm kernel:  [<c0127fdf>] do_exit+0x19c/0x5ae
Aug 31 10:37:06 ibm kernel:  [<c012e39b>] ? recalc_sigpending+0xd/0x30
Aug 31 10:37:06 ibm kernel:  [<c01309c4>] ? dequeue_signal+0x9d/0x108
Aug 31 10:37:06 ibm kernel:  [<c0128453>] do_group_exit+0x62/0x88
Aug 31 10:37:06 ibm kernel:  [<c0130f7b>] get_signal_to_deliver+0x368/0x38d
Aug 31 10:37:06 ibm kernel:  [<c0101dd0>] do_notify_resume+0x75/0x6af
Aug 31 10:37:06 ibm kernel:  [<c0168014>] ? unlock_page+0x3d/0x40
Aug 31 10:37:06 ibm kernel:  [<c02da2b1>] ? do_page_fault+0x312/0x340
Aug 31 10:37:06 ibm kernel:  [<c0144463>] ? sys_futex+0xe9/0xff
Aug 31 10:37:06 ibm kernel:  [<c018007b>] ? vread+0x1f/0x8d
Aug 31 10:37:06 ibm kernel:  [<c0102a06>] work_notifysig+0x13/0x19
Aug 31 10:37:06 ibm kernel: ---[ end trace 4eaa2a86a8e2da25 ]---
Aug 31 10:37:06 ibm kernel: entry->group=(null) inode=(null) wd=-1
Comment 3 Joerg Platte 2009-10-02 09:16:37 UTC
I did not encounter any inotify-related bug with 2.6.31 and 2.6.31.1 so far. Looks like you can close this bug.
Comment 4 Andrey Rahmatullin 2009-10-09 07:09:43 UTC
2.6.31:

------------[ cut here ]------------
WARNING: at fs/notify/inotify/inotify_fsnotify.c:129 idr_callback+0x3c/0x71()
Hardware name: KT600-8237
inotify closing but id=0 for entry=f33c3fc0 in group=f33c1800 still in idr.  Probably leaking memory
Modules linked in: nf_conntrack_ftp sha256_generic cbc dm_crypt nfsd lockd nfs_acl auth_rpcgss sunrpc loop cdc_acm usb_storage usb_libusual radeon drm i2c_core vboxnetadp vboxnetflt vboxdrv w83627hf hwmon_vid aes_i586 aes_generic af_packet ppp_deflate zlib_deflate bsd_comp ppp_async crc_ccitt ppp_generic slhc bridge stp llc via_rhine mii ipt_LOG xt_limit ipt_REJECT xt_tcpudp xt_state xt_mac iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 iptable_filter ip_tables x_tables nls_cp1251 nls_cp866 vfat fat ext3 jbd mbcache arc4 ecb snd_via82xx snd_ac97_codec ac97_bus snd_pcm snd_timer snd_page_alloc rt61pci snd_mpu401_uart crc_itu_t snd_rawmidi snd_seq_device evdev rt2x00pci snd rt2x00lib hid_a4tech input_polldev sr_mod cdrom soundcore mac80211 fan cfg80211 serial_core via_agp agpgart processor thermal button eeprom_93cx6 thermal_sys hwmon dm_mod fuse usbhid hid uhci_hcd ehci_hcd usbcore nls_base pata_via
Pid: 5902, comm: kded4 Tainted: G        W  2.6.31-wrar-8 #1
Call Trace:
 [<c012aa45>] warn_slowpath_common+0x70/0x98
 [<c01ce141>] ? idr_callback+0x3c/0x71
 [<c012aacc>] warn_slowpath_fmt+0x2f/0x43
 [<c01ce141>] idr_callback+0x3c/0x71
 [<c026703c>] idr_for_each+0x68/0xb4
 [<c01ce105>] ? idr_callback+0x0/0x71
 [<c01cc4ab>] ? fsnotify_put_event+0x50/0x65
 [<c01ce0e2>] inotify_free_group_priv+0x24/0x47
 [<c01cc609>] fsnotify_final_destroy_group+0x29/0x45
 [<c01cc702>] fsnotify_put_group+0x7d/0x92
 [<c01ce338>] inotify_release+0x27/0x42
 [<c01a7475>] __fput+0xe7/0x1a0
 [<c01a754f>] fput+0x21/0x36
 [<c01a4212>] filp_close+0x5f/0x7a
 [<c012c3ca>] put_files_struct+0x62/0xb7
 [<c012c44b>] exit_files+0x2c/0x3f
 [<c012db25>] do_exit+0x16d/0x556
 [<c012df68>] do_group_exit+0x5a/0x80
 [<c0136f61>] get_signal_to_deliver+0x2a8/0x2cf
 [<c01029d4>] do_notify_resume+0x80/0x736
 [<c0120264>] ? kunmap_atomic+0x60/0x81
 [<c018feb7>] ? do_wp_page+0x531/0x5c7
 [<c01203e0>] ? kmap_atomic_prot+0xab/0xd8
 [<c01913b3>] ? handle_mm_fault+0x639/0x6cb
 [<c0143f35>] ? clocksource_read+0x19/0x2e
 [<c01445c6>] ? getnstimeofday+0x5a/0xef
 [<c026e5af>] ? might_fault+0x16/0x29
 [<c01b2e23>] ? sys_poll+0x4e/0xa5
 [<c013c052>] ? sys_clock_gettime+0x73/0x9b
 [<c010378c>] work_notifysig+0x13/0x1b
---[ end trace 6bb70e430853ee84 ]---
entry->group=(null) inode=(null) wd=-1
Comment 5 Eric Paris 2009-10-09 12:52:59 UTC
The commit at:

http://git.infradead.org/users/eparis/notify.git/commitdiff/ead19115fd40387df98c4a16df03c6bf2bf46edb

Should solve this problem.  Anyone who can reliably reproduce this problem I would like to have test this patch.  If anyone can confirm it works I'll send it to linus.

-Eric
Comment 6 Michael Tokarev 2009-10-27 11:29:29 UTC
I've quite alot of these happening here on 2.6.31.4, with dovecot imapd.  The only "issue" is that it's a virtual machine (kvm), but this part of the kernel should be the same anyway.

WARNING: at fs/notify/inotify/inotify_fsnotify.c:129 idr_callback+0x3e/0x70()
Hardware name: 
inotify closing but id=0 for entry=f690f49c in group=f696c940 still in idr.  Probably leaking memory
Modules linked in: virtio_rng rng_core squashfs loop nfsd lockd nfs_acl auth_rpcgss sunrpc exportfs autofs4 button quota_v2 quota_tree ext4 jbd2 crc16 ext3 jbd mbcache virtio_net virtio_blk virtio_pci virtio_ring virtio
Pid: 3809, comm: imap Tainted: G S      W  2.6.31-i686 #2.6.31.4
Call Trace:
 [<c10f3c0e>] ? idr_callback+0x3e/0x70
 [<c10f3c0e>] ? idr_callback+0x3e/0x70
 [<c103b996>] ? warn_slowpath_common+0x76/0xd0
 [<c10f3c0e>] ? idr_callback+0x3e/0x70
 [<c103ba3b>] ? warn_slowpath_fmt+0x2b/0x30
 [<c10f3c0e>] ? idr_callback+0x3e/0x70
 [<c11386ea>] ? idr_for_each+0x6a/0xc0
 [<c10f3bd0>] ? idr_callback+0x0/0x70
 [<c10f3bb2>] ? inotify_free_group_priv+0x12/0x30
 [<c10f1e26>] ? fsnotify_final_destroy_group+0x16/0x20
 [<c10f3dce>] ? inotify_release+0x1e/0x40
 [<c10c7f3a>] ? __fput+0xca/0x1d0
 [<c10c4d47>] ? filp_close+0x47/0x80
 [<c10c4de8>] ? sys_close+0x68/0xb0
 [<c1002f58>] ? sysenter_do_call+0x12/0x2c
---[ end trace 4eaa2a86a8e2da2b ]---
entry->group=(null) inode=(null) wd=1024

That's all the entry->group lines so far:

entry->group=(null) inode=(null) wd=1024
entry->group=(null) inode=(null) wd=1024
entry->group=(null) inode=(null) wd=-1
entry->group=(null) inode=(null) wd=-1
entry->group=(null) inode=(null) wd=1024
entry->group=(null) inode=(null) wd=1024

This machine had an OOM today (at squashfs mount), so I'll reboot it tonight (it's a production server).  Can as well try any debug patches...
Comment 7 Eric Paris 2009-10-27 13:41:31 UTC
the fix was pulled by Linus by commit 9f0d793b52eb2266359661369ef6303838904855 which should appear in 32-rc6.  It has been forwarded to the the .31 stable team but I have not heard when it will appear their.  If you know how to build you own kernel that commit should apply cleanly and resolv the problem.
Comment 8 Rafael J. Wysocki 2009-10-27 20:22:30 UTC
On Tuesday 27 October 2009, Eric Paris wrote:
> On Mon, Oct 26, 2009 at 3:31 PM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.30 and 2.6.31.
> >
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.30 and 2.6.31.  Please verify if it still should
> > be listed and let me know (either way).
> >
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=14090
> > Subject         : WARNING: at fs/notify/inotify/inotify_user.c:394
> > Submitter       : Joerg Platte <bugzilla@jako.ping.de>
> > Date            : 2009-08-30 15:21 (58 days old)
> 
> should be fixed by: 9f0d793b52eb2266359661369ef6303838904855 in linus' tree
Comment 9 Igor Novgorodov 2009-12-28 06:46:23 UTC
The issue is still present in 2.6.32.2:

[189824.600064] ------------[ cut here ]------------
[189824.600087] WARNING: at fs/notify/inotify/inotify_fsnotify.c:129 idr_callback+0x36/0x60()
[189824.600090] Hardware name: VMware Virtual Platform
[189824.600092] inotify closing but id=0 for entry=ffff88023db1a9a0 in group=ffff8801d8eedf00 still in idr.  Probably leaking memory
[189824.600095] Modules linked in:
[189824.600098] Pid: 26618, comm: imap Not tainted 2.6.32.2-VMWARE #1
[189824.600101] Call Trace:
[189824.600105]  [<ffffffff810e0326>] ? idr_callback+0x36/0x60
[189824.600108]  [<ffffffff810e0326>] ? idr_callback+0x36/0x60
[189824.600112]  [<ffffffff8103f404>] ? warn_slowpath_common+0x74/0xd0
[189824.600116]  [<ffffffff8103f4c1>] ? warn_slowpath_fmt+0x51/0x60
[189824.600121]  [<ffffffff814689bc>] ? _spin_lock_irq+0xc/0x10
[189824.600125]  [<ffffffff81466576>] ? wait_for_common+0x156/0x1a0
[189824.600129]  [<ffffffff8103b330>] ? default_wake_function+0x0/0x10
[189824.600132]  [<ffffffff810e0326>] ? idr_callback+0x36/0x60
[189824.600137]  [<ffffffff812645c4>] ? idr_for_each+0x84/0xe0
[189824.600139]  [<ffffffff810e02f0>] ? idr_callback+0x0/0x60
[189824.600144]  [<ffffffff810de5c7>] ? fsnotify_remove_priv_from_event+0x17/0x90
[189824.600147]  [<ffffffff810e02da>] ? inotify_free_group_priv+0x1a/0x30
[189824.600150]  [<ffffffff810de7db>] ? fsnotify_final_destroy_group+0x1b/0x30
[189824.600154]  [<ffffffff810e056c>] ? inotify_release+0x2c/0x50
[189824.600158]  [<ffffffff810af63d>] ? __fput+0xcd/0x1f0
[189824.600161]  [<ffffffff810abb1a>] ? filp_close+0x4a/0x80
[189824.600164]  [<ffffffff810abc03>] ? sys_close+0xb3/0x120
[189824.600168]  [<ffffffff8100b482>] ? system_call_fastpath+0x16/0x1b
[189824.600170] ---[ end trace fab63940f8ddf26e ]---
[189824.600172] entry->group=(null) inode=(null) wd=4096
Comment 10 Christian Kujau 2010-01-06 20:13:41 UTC
As reported earlier, 2.6.32 still has this warning:

http://lkml.indiana.edu/hypermail/linux/kernel/0912.1/03373.html

This is with v2.6.32:


Jan  6 13:38:50
------------[ cut here ]------------
WARNING: at /data/Scratch/scm/linux-2.6-git/fs/notify/inotify/inotify_fsnotify.c:129 idr_callback+0x36/0x60()
inotify closing but id=0 for entry=ffff88003278fee0 in group=ffff880032799a00 still in idr.  Probably leaking memory
Modules linked in: xfs sha256_generic aes_x86_64 aes_generic ipv6 tun jfs nls_base nfsd lockd auth_rpcgss sunrpc exportfs reiserfs fuse twofish_x86_64 twofish_co
mmon
Pid: 8751, comm: imap Not tainted 2.6.32 #1
Call Trace:
 [<ffffffff810ce906>] ? idr_callback+0x36/0x60
 [<ffffffff810ce906>] ? idr_callback+0x36/0x60
 [<ffffffff810352c9>] ? warn_slowpath_common+0x79/0xd0
 [<ffffffff81035381>] ? warn_slowpath_fmt+0x51/0x60
 [<ffffffff8120326c>] ? _spin_lock_irq+0xc/0x10
 [<ffffffff81200bcf>] ? wait_for_common+0x15f/0x1a0
 [<ffffffff8100e4b2>] ? check_events+0x12/0x20
 [<ffffffff81028830>] ? check_preempt_curr_idle+0x0/0x10
 [<ffffffff810cd627>] ? fsnotify_flush_notify+0x97/0xc0
 [<ffffffff8100dd99>] ? xen_force_evtchn_callback+0x9/0x10
 [<ffffffff8100e4b2>] ? check_events+0x12/0x20
 [<ffffffff81028830>] ? check_preempt_curr_idle+0x0/0x10
 [<ffffffff810ce906>] ? idr_callback+0x36/0x60
 [<ffffffff81138d04>] ? idr_for_each+0x84/0xe0
 [<ffffffff810ce8d0>] ? idr_callback+0x0/0x60
 [<ffffffff8100e49f>] ? xen_restore_fl_direct_end+0x0/0x1
 [<ffffffff81096a77>] ? kmem_cache_free+0x87/0xc0
 [<ffffffff810ce8ba>] ? inotify_free_group_priv+0x1a/0x30
 [<ffffffff810cd6cb>] ? fsnotify_final_destroy_group+0x1b/0x30
 [<ffffffff810ceb4c>] ? inotify_release+0x2c/0x50
 [<ffffffff8109e450>] ? __fput+0xc0/0x1f0
 [<ffffffff8109a9cb>] ? filp_close+0x5b/0x90
 [<ffffffff8109aab3>] ? sys_close+0xb3/0x120
 [<ffffffff81010d42>] ? system_call_fastpath+0x16/0x1b
---[ end trace 5de603824b6bef55 ]---
entry->group=(null) inode=(null) wd=4096
------------[ cut here ]------------


Jan  6 13:52:07
------------[ cut here ]------------
WARNING: at /data/Scratch/scm/linux-2.6-git/fs/notify/inotify/inotify_fsnotify.c:129 idr_callback+0x36/0x60()
inotify closing but id=0 for entry=ffff88004f8c0d90 in group=ffff880034528200 still in idr.  Probably leaking memory
Modules linked in: xfs sha256_generic aes_x86_64 aes_generic ipv6 tun jfs nls_base nfsd lockd auth_rpcgss sunrpc exportfs reiserfs fuse twofish_x86_64 twofish_common
Pid: 14969, comm: imap Tainted: G        W  2.6.32 #1
Call Trace:
 [<ffffffff810ce906>] ? idr_callback+0x36/0x60
 [<ffffffff810ce906>] ? idr_callback+0x36/0x60
 [<ffffffff810352c9>] ? warn_slowpath_common+0x79/0xd0
 [<ffffffff81035381>] ? warn_slowpath_fmt+0x51/0x60
 [<ffffffff8100dd99>] ? xen_force_evtchn_callback+0x9/0x10
 [<ffffffff8100e4b2>] ? check_events+0x12/0x20
 [<ffffffff810cd627>] ? fsnotify_flush_notify+0x97/0xc0
 [<ffffffff8100dd99>] ? xen_force_evtchn_callback+0x9/0x10
 [<ffffffff8100e4b2>] ? check_events+0x12/0x20
 [<ffffffff810ce906>] ? idr_callback+0x36/0x60
 [<ffffffff81138d04>] ? idr_for_each+0x84/0xe0
 [<ffffffff810ce8d0>] ? idr_callback+0x0/0x60
 [<ffffffff8100e49f>] ? xen_restore_fl_direct_end+0x0/0x1
 [<ffffffff81096a77>] ? kmem_cache_free+0x87/0xc0
 [<ffffffff810ce8ba>] ? inotify_free_group_priv+0x1a/0x30
 [<ffffffff810cd6cb>] ? fsnotify_final_destroy_group+0x1b/0x30
 [<ffffffff810ceb4c>] ? inotify_release+0x2c/0x50
 [<ffffffff8109e450>] ? __fput+0xc0/0x1f0
 [<ffffffff8109a9cb>] ? filp_close+0x5b/0x90
 [<ffffffff8109aab3>] ? sys_close+0xb3/0x120
 [<ffffffff81010d42>] ? system_call_fastpath+0x16/0x1b
---[ end trace 5de603824b6bef56 ]---
entry->group=(null) inode=(null) wd=4096
Comment 11 Kadianakis George 2010-04-08 14:51:29 UTC
Another log from a patched kernel (2.6.31.6):

[6505880.619291] WARNING: at fs/notify/inotify/inotify_fsnotify.c:129
idr_callback+0x3e/0x62()
[6505880.619293] Hardware name: MS-7368
[6505880.619295] inotify closing but id=0 for entry=ffff8800520a58c0 in
group=ffff88007dbbb300 still in idr.  Probably leaking memory
[6505880.619298] Modules linked in:
[6505880.619302] Pid: 872, comm: udevd Not tainted 2.6.31-gentoo-r6 #2
[6505880.619304] Call Trace:
[6505880.619308]  [<ffffffff810fc4db>] ? idr_callback+0x3e/0x62
[6505880.619311]  [<ffffffff8103f89c>] warn_slowpath_common+0x77/0xa4
[6505880.619314]  [<ffffffff8103f93e>] warn_slowpath_fmt+0x64/0x66
[6505880.619318]  [<ffffffff810a30c4>] ? free_hot_page+0xb/0xd
[6505880.619321]  [<ffffffff810a30e1>] ? __free_pages+0x1b/0x24
[6505880.619324]  [<ffffffff810ca36e>] ? __free_slab+0x121/0x12e
[6505880.619327]  [<ffffffff810fa62c>] ? fsnotify_put_event+0x54/0x58
[6505880.619330]  [<ffffffff810ca3c8>] ? discard_slab+0x4d/0x4f
[6505880.619332]  [<ffffffff810ca8a2>] ? __slab_free+0xea/0x2d3
[6505880.619335]  [<ffffffff810fc4db>] idr_callback+0x3e/0x62
[6505880.619339]  [<ffffffff81263146>] idr_for_each+0x6f/0xb2
[6505880.619341]  [<ffffffff810fc49d>] ? idr_callback+0x0/0x62
[6505880.619344]  [<ffffffff810fa62c>] ? fsnotify_put_event+0x54/0x58
[6505880.619347]  [<ffffffff810fc489>] inotify_free_group_priv+0x22/0x36
[6505880.619349]  [<ffffffff810fa74b>] fsnotify_final_destroy_group+0x23/0x2f
[6505880.619352]  [<ffffffff810fa833>] fsnotify_put_group+0x8f/0x93
[6505880.619355]  [<ffffffff810fc689>] inotify_release+0x25/0x37
[6505880.619358]  [<ffffffff810d308e>] __fput+0xf6/0x1bb
[6505880.619361]  [<ffffffff810d316b>] fput+0x18/0x1a
[6505880.619364]  [<ffffffff810d030e>] filp_close+0x67/0x72
[6505880.619366]  [<ffffffff81041280>] put_files_struct+0x6b/0xc2
[6505880.619369]  [<ffffffff8104131e>] exit_files+0x47/0x50
[6505880.619372]  [<ffffffff81042a90>] do_exit+0x1f6/0x722
[6505880.619376]  [<ffffffff81057c1f>] ? up_read+0x9/0xb
[6505880.619380]  [<ffffffff81520142>] ? do_page_fault+0x28a/0x2bc
[6505880.619383]  [<ffffffff8104302e>] do_group_exit+0x72/0x9f
[6505880.619385]  [<ffffffff8104306d>] sys_exit_group+0x12/0x16
[6505880.619390]  [<ffffffff8100b9eb>] system_call_fastpath+0x16/0x1b
[6505880.619392] ---[ end trace 9d2bfe27f1c3ab57 ]---
[6505880.619394] entry->group=(null) inode=(null) wd=4096
[6505881.628794] udev: starting version 149

[http://bugs.gentoo.org/show_bug.cgi?id=290651]

If you need any extra info, ask so and I will request it from the original bug reporter.

Note You need to log in before you can comment on or make changes to this bug.