Bug 14081 - MSI EC special treatment enabled for non-MSI notebooks
MSI EC special treatment enabled for non-MSI notebooks
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: EC
All Linux
: P1 normal
Assigned To: Alexey Starikovskiy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-28 16:28 UTC by Ryan Underwood
Modified: 2009-10-06 02:22 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.31-rc8
Tree: Mainline
Regression: No


Attachments
dmidecode (8.70 KB, text/plain)
2009-08-29 19:44 UTC, Ryan Underwood
Details

Description Ryan Underwood 2009-08-28 16:28:12 UTC
The following code:

if (dmi_name_in_vendors("Micro-Star") ||
        dmi_name_in_vendors("Notebook")) {
    pr_info(PREFIX "Enabling special treatment for EC from MSI.\n");
    EC_FLAGS_MSI = 1;
}

enables MSI workaround on all notebooks, introducing delays into EC handling.  The || should probably be && instead.
Comment 1 Alexey Starikovskiy 2009-08-28 16:38:06 UTC
No, "Notebook" in vendor field of DMI is specific to MSI, as I am aware of.
So, || is intended.
Comment 2 Ryan Underwood 2009-08-28 23:10:47 UTC
I beg to differ.  My laptop includes "Notebook" in the product name.  Why would you think that this would somehow identify a MSI laptop?

Manufacturer: Hewlett-Packard
Product Name: HP Pavilion dv2700 Notebook PC

If this _really_ is intended, can you explain why it would make any sense to enable a MSI bug workaround on my laptop?  I still detect bogons.
Comment 3 Ryan Underwood 2009-08-28 23:12:43 UTC
I believe you may be misinterpreting the effect of the (poorly-named) function dmi_name_in_vendors().  It searches a haystack of several DMI strings, not just the DMI vendor string.
Comment 4 Alexey Starikovskiy 2009-08-29 06:53:06 UTC
please provide output of dmidecode for your machine.
Comment 5 Ryan Underwood 2009-08-29 19:44:37 UTC
Created attachment 22902 [details]
dmidecode
Comment 6 Alexey Starikovskiy 2009-08-30 16:36:58 UTC
please check if the patch http://bugzilla.kernel.org/attachment.cgi?id=22911
works for you.
Comment 7 Ryan Underwood 2009-08-30 18:01:20 UTC
Testing.  By the way, the comment for ACPI_EC_DELAY is also wrong, it is a 500us delay, not a 500ms delay.
Comment 8 Alexey Starikovskiy 2009-08-30 18:13:40 UTC
No, it is half a second. Same name was used for MSI workaround, and there it is in usec. There is a patch already, which splits MSI specific value apart.
Comment 9 Ryan Underwood 2009-09-04 04:01:11 UTC
The patch works, so please apply to mainline.
Comment 10 Len Brown 2009-10-06 02:22:29 UTC
commit 0adf3c746a73684b3f8c2821a584e1db998f61e9

    ACPI: EC: Rewrite DMI checks

shipped in Linux-2.6.32-rc3
closed

Note You need to log in before you can comment on or make changes to this bug.