Bug 14074 - Oops on disk access after suspend/resume
Oops on disk access after suspend/resume
Status: RESOLVED DUPLICATE of bug 13149
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-27 16:14 UTC by Gavin Kinsey
Modified: 2009-09-10 02:12 UTC (History)
0 users

See Also:
Kernel Version: 2.6.31-rc7
Tree: Mainline
Regression: Yes


Attachments
dmesg output before the suspend (45.94 KB, text/plain)
2009-08-27 16:14 UTC, Gavin Kinsey
Details
Oops captured from a netconsole (6.08 KB, text/plain)
2009-08-27 16:15 UTC, Gavin Kinsey
Details
Kernel config (103.60 KB, text/plain)
2009-08-27 16:15 UTC, Gavin Kinsey
Details
lspci -vvv (29.88 KB, text/plain)
2009-08-27 16:16 UTC, Gavin Kinsey
Details
Output of ver_linux script (1.74 KB, text/plain)
2009-08-27 16:16 UTC, Gavin Kinsey
Details

Description Gavin Kinsey 2009-08-27 16:14:03 UTC
Created attachment 22882 [details]
dmesg output before the suspend

For a while now I have had crashes on newer kernels that I was unable to track the cause of.  I've finally managed to nail down a test case for it now though.  It seems that there is a problem with some disk accesses after a suspend/resume, it doesn't happen on the first access but some time later which is what made it hard for me to identify.

The following will always cause the error to show up though:
1) Boot and login as root
2) Suspend using pm-suspend
3) Resume with power button
4) Run "find / -xdev -type f | xargs -t -l1 cat > /dev/null"

At some point during that find command the kernel will Oops.

The last kernel that definitely worked was v2.6.27.  I've done a git bisect and I believe the problem commit to be e621bd18958ef5dbace3129ebe17a0a475e127d9 and indeed reverting that commit on a v2.6.28 codebase does fix my problem.

I've been unable to generate a working patch for v2.6.31, and even if I could I don't think just reverting the commit is the correct solution as the commit was a bug fix itself.

Relevant logs attached.
Comment 1 Gavin Kinsey 2009-08-27 16:15:00 UTC
Created attachment 22883 [details]
Oops captured from a netconsole
Comment 2 Gavin Kinsey 2009-08-27 16:15:28 UTC
Created attachment 22884 [details]
Kernel config
Comment 3 Gavin Kinsey 2009-08-27 16:16:01 UTC
Created attachment 22885 [details]
lspci -vvv
Comment 4 Gavin Kinsey 2009-08-27 16:16:32 UTC
Created attachment 22886 [details]
Output of ver_linux script
Comment 5 Gavin Kinsey 2009-09-10 02:12:22 UTC
I believe this is the same bug as #13149.

*** This bug has been marked as a duplicate of bug 13149 ***

Note You need to log in before you can comment on or make changes to this bug.