Bug 14062 - Failure to boot as xen guest
Failure to boot as xen guest
Status: CLOSED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: Slab Allocator
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-08-25 22:44 UTC by Rafael J. Wysocki
Modified: 2009-09-06 19:58 UTC (History)
0 users

See Also:
Kernel Version: 2.6.31-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-08-25 22:44:38 UTC
Subject    : [bisected] 2.6.31 regression: fails to boot as xen guest
Submitter  : Arnd Hannemann <hannemann@nets.rwth-aachen.de>
Date       : 2009-08-25 15:48
References : http://marc.info/?l=linux-kernel&m=125121534229538&w=4
Handled-By : Jeremy Fitzhardinge <jeremy@goop.org>
Patch      : http://patchwork.kernel.org/patch/43799/

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 83b519e8b9572c319c8e0c615ee5dd7272856090
Author: Pekka Enberg <penberg@cs.helsinki.fi>
Date:   Wed Jun 10 19:40:04 2009 +0300

    slab: setup allocators earlier in the boot sequence

First-Bad-Commit : 83b519e8b9572c319c8e0c615ee5dd7272856090
Comment 1 Rafael J. Wysocki 2009-09-06 19:58:32 UTC
Fixed by commit d560bc61575efae43595cbcb56d0ba3b9450139c.

Note You need to log in before you can comment on or make changes to this bug.