Bug 14060 - oops: sysfs_remove_link and i915
oops: sysfs_remove_link and i915
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Power-Video
All Linux
: P1 normal
Assigned To: Zhang Rui
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-08-25 22:23 UTC by Rafael J. Wysocki
Modified: 2009-08-30 03:34 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.31-rc7
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-08-25 22:23:04 UTC
Subject    : oops: sysfs_remove_link, i915 and 2.6.31-rc7
Submitter  : Dominik Brodowski <linux@dominikbrodowski.net>
Date       : 2009-08-22 5:48
References : http://marc.info/?l=linux-kernel&m=125092139113955&w=4

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Zhang Rui 2009-08-26 01:31:49 UTC
the bug should be fixed by http://patchwork.kernel.org/patch/39704/

Rafael, please ask Dominik to try the patch. :)
Comment 2 ykzhao 2009-08-26 15:04:18 UTC
I can reproduce this issue on one box. And I can confirm that the issue can be fixed by the patch in http://patchwork.kernel.org/patch/39704/.
thanks.
Comment 3 Dominik Brodowski 2009-08-26 20:45:57 UTC
Tried the patch, and it fixes the oops.
Comment 4 Rafael J. Wysocki 2009-08-26 21:27:11 UTC
Handled-By : Keith Packard <keithp@keithp.com>
Patch : http://patchwork.kernel.org/patch/39704/
Comment 5 Len Brown 2009-08-30 03:34:40 UTC
e29b3ee3b005897fbdcfdd4b3190776e38739d70
ACPI: don't free non-existent backlight in acpi video module

shipped in v2.6.31-rc8

closed.

Note You need to log in before you can comment on or make changes to this bug.