Bug 14041 - Computer doesn't resume normally after software suspend
Computer doesn't resume normally after software suspend
Status: CLOSED INVALID
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
i386 Linux
: P1 blocking
Assigned To: ykzhao
:
: 13225 (view as bug list)
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2009-08-23 06:13 UTC by Artem S. Tashkinov
Modified: 2009-09-22 04:00 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.31
Tree: Mainline
Regression: No


Attachments
Hardware and software info (39.09 KB, application/octet-stream)
2009-08-23 06:13 UTC, Artem S. Tashkinov
Details
dmesg before suspending (12.98 KB, application/octet-stream)
2009-08-26 17:17 UTC, Artem S. Tashkinov
Details

Description Artem S. Tashkinov 2009-08-23 06:13:58 UTC
Created attachment 22816 [details]
Hardware and software info

The computer suspends successfully but then I cannot wake it up - it powers on but the screen remains black, network interfaces are inaccessible, keyboard buttons are not working
(leds cannot be changed by pressing Caps Lock/Scroll Lock/etc). System fan after resuming is roaring (before suspend I make `echo 70 > /sys/devices/platform/it87.656/pwm2` to slow it down).

Relevant hardware information is attached (as well as .config/dmesg/lspci/etc).

This happens with or without VESA console.

There are no working kernels.
Comment 1 ykzhao 2009-08-26 16:03:09 UTC
Will you please do the following test on the latest kernel?
   a. kill the process which is using /proc/acpi/event(using the command of "lsof /proc/acpi/event")
   b. echo mem > /sys/power/state; dmesg >dmesg_after; sync;
   c. press the power button and see whether it can be resumed.
   d. if it can't be resumed, please reboot the system and see whether the file of dmesg_after is created.
   
If it is created, please attach it.
   thanks.
Comment 2 Artem S. Tashkinov 2009-08-26 17:17:49 UTC
Created attachment 22865 [details]
dmesg before suspending

dmesg_after is not there after reboot.

Kernel is NOT tainted.
Comment 3 ykzhao 2009-09-07 02:20:19 UTC
Hi, Artem
    Sorry for the late response. 
    From the test it seems that the system can't be resumed. Maybe it is related with BIOS. Unfortunately now we have no idea about this issue.
    And we see this issue on many laptops.

    This bug will be marked as the duplicated of bug 11255.
    Thanks.
Comment 4 ykzhao 2009-09-07 02:22:17 UTC

*** This bug has been marked as a duplicate of bug 11255 ***
Comment 5 Artem S. Tashkinov 2009-09-15 11:15:39 UTC
*** Bug 13225 has been marked as a duplicate of this bug. ***
Comment 6 Artem S. Tashkinov 2009-09-15 11:16:33 UTC
Zhang,

Speaking frankly I don't know what to do with this bug, because my PC (not a laptop BTW), doesn't resume even with kernel 2.6.28.10 (as opposed to the initial bug report).

I'm closing the bug, until I have enough time to remove all peripherals one by one in order to find a piece of hardware which makes the kernel unable to resume (probably I will even have to disable PAE support in kernel) - I ain't an ACPI specialist :(

I'm greatly disappointed because Windows XP SP3 on the same PC works just fine.
Comment 7 Artem S. Tashkinov 2009-09-16 05:56:40 UTC
It's not a duplicate of bug 11255.

I initially opened bug 13225. (See numbers are very similar).

I'm sorry for the mess.
Comment 8 ykzhao 2009-09-21 03:30:38 UTC
Hi, Artem
    Is the same box used in the bug 14041 and 13225?
    From the info in bug 13225 it seems that the box can be resumed. But the screen is not restored correctly. Right? How about using the vbetool?
    From the log in comment #2 it seems that there is no file of dmesg_after after suspend/resume. So I mark it as the dup of bug 11255.

Thanks.
Comment 9 Artem S. Tashkinov 2009-09-21 03:57:14 UTC
Yes, it is the same box.

Actually you have forgotten to mark this bug as a duplicate - ok, I'll do that.

*** This bug has been marked as a duplicate of bug 11255 ***
Comment 10 Artem S. Tashkinov 2009-09-22 04:00:55 UTC
Closing it as invalid - my computer cannot resume even with Windows XP SP3.

Possible causes:
1) Broken motherboard (I have a slightly inflated capacitor);
2) Broken BIOS (I have a beta version installed);
3) Broken other hardware (not sure if it's possible - but who knows).

Note You need to log in before you can comment on or make changes to this bug.