Bug 14026 - USB randomly crashes
USB randomly crashes
Status: CLOSED INVALID
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 high
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2009-08-20 13:06 UTC by Matthew Gyurgyik
Modified: 2009-08-25 21:33 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.31rc6
Tree: Mainline
Regression: Yes


Attachments
2.6.31rc6 kernel log (111.12 KB, text/plain)
2009-08-20 13:06 UTC, Matthew Gyurgyik
Details
dmesg log 2.6.31rc6 (75.69 KB, text/plain)
2009-08-20 13:07 UTC, Matthew Gyurgyik
Details
2.6.30.5 demsg log (47.30 KB, text/plain)
2009-08-20 13:08 UTC, Matthew Gyurgyik
Details
kernel.log w/ Sysrq+T output (42 bytes, text/plain)
2009-08-21 00:11 UTC, Matthew Gyurgyik
Details

Description Matthew Gyurgyik 2009-08-20 13:06:52 UTC
Created attachment 22788 [details]
2.6.31rc6 kernel log

Hello!

The usb subsystem seems to completely crash at random intervals of time. Sometime it happens 5 minutes from boot, sometimes 30 mins, and sometime 5-8hrs from boot. I first experienced this issue somewhere in the 2.6.30.* tree.

Usually what happens is that I will be using X and my mouse stops responding. As you probably figured my mouse is a usb mouse. However, I can use the keyboard (non-usb) and X is still alive. If I attempt to plug in a usb flash drive nothing shows up in dmesg (2.6.31rc6) or on 2.6.30.5 I get a kernel trace.

I have attached the dmesg and kernel.log files from 2.6.31rc6 along with the dmesg output from 2.6.30.5.

Let me know how I can help or if you need any more information.
Comment 1 Matthew Gyurgyik 2009-08-20 13:07:37 UTC
Created attachment 22789 [details]
dmesg log 2.6.31rc6
Comment 2 Matthew Gyurgyik 2009-08-20 13:08:19 UTC
Created attachment 22790 [details]
2.6.30.5 demsg log
Comment 3 Greg Kroah-Hartman 2009-08-20 13:14:35 UTC
Can you provide the output in the kernel log for running Alt-Sysrq-T when you feel the USB subsystem is locked up?  We need some hint as to what is going on here.
Comment 4 Matthew Gyurgyik 2009-08-20 13:43:07 UTC
Alright, I will do that the next time the usb system locks up.
Comment 5 Matthew Gyurgyik 2009-08-21 00:11:26 UTC
Created attachment 22797 [details]
kernel.log w/ Sysrq+T output

Sysrq+T output around 19:08
Comment 6 Matthew Gyurgyik 2009-08-21 00:14:20 UTC
This time the freeze happened when I was away from the computer so I am not sure if the Sysrq+T output will be helpful.

However, I rmmod ehci_hcd and that resulted in usb working again. After, I modprobe ehci_hcd and usb continues to work, for right now. I suppose this suggests that the ehci_hcd module is the one causing problems.
Comment 7 Roland Kletzing 2009-08-21 09:54:08 UTC
>I first experienced this issue somewhere in the 2.6.30.* tree.

that means it did not happen with older kernel releases ?
if you are unsure, could you test with older kernels?
Comment 8 Matthew Gyurgyik 2009-08-21 20:34:14 UTC
That would be correct. I built this machine in July, when I believe the kernel release was at 2.6.27 or 2.6.28 and usb was fine. I'd say within the last month I started noticing problems.
Comment 9 Roland Kletzing 2009-08-21 22:47:59 UTC
would you dare to try git-bisecting this problem or at least try to determine, which kernel release worked without problems and with what kernel release the problem started to happen ?  having exact information like that makes troubleshooting easier....
Comment 10 Matthew Gyurgyik 2009-08-22 01:10:45 UTC
I will try to narrow it down to the first major release in which the problem started to occur. Then I will do a git bisect. This might take a while, because I may not experience the problem for 7-8hrs.
Comment 11 Matthew Gyurgyik 2009-08-25 14:29:35 UTC
Just an update. I updated the nvidia drivers to the newest beta release and it seems as if the problem has gone away. I haven't experienced the issue for the past two days.

It seems that the binary drivers were some how taunting the kernel's usb subsystem.
Comment 12 Greg Kroah-Hartman 2009-08-25 16:33:14 UTC
Imagine that :(

thanks for letting us know, I'll close this out.
Comment 13 Roland Kletzing 2009-08-25 18:02:38 UTC
another proof, that kernel issues with closed-sourc modules loaded shouldn´t be investigated until those modules are unloaded. i have overseen that the kernel was tainted.....

Note You need to log in before you can comment on or make changes to this bug.