Bug 14025 - Second resume after sleep doesn't work unlress I disable second core in bios - Toshiba L300-F
Second resume after sleep doesn't work unlress I disable second core in bios ...
Status: CLOSED UNREPRODUCIBLE
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
All Linux
: P1 normal
Assigned To: acpi_power-sleep-wake
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-20 12:34 UTC by Sebastian Zazula
Modified: 2009-11-25 05:12 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.30.4
Tree: Mainline
Regression: No


Attachments
acpidump (153.41 KB, application/octet-stream)
2009-09-03 13:10 UTC, Sebastian Zazula
Details

Description Sebastian Zazula 2009-08-20 12:34:10 UTC
I am using Toshiba L300-F and after changing CPU from celeron to core2duo resume fails in second sleep/resume cycle. When I disable second core in bios i can sleep/resume machine as many times as I want. "echo 0 > /sys/devices/system/cpu/ cpu1/online" doesn't work,
Comment 1 Zhang Rui 2009-08-21 03:42:28 UTC
please try the patch at http://patchwork.kernel.org/patch/38246/ and see if it
helps.
Comment 2 ykzhao 2009-08-31 08:06:36 UTC
hi, Sebastian
    Will you please also attach the output of acpidump?

Thanks.
Comment 3 Zhang Rui 2009-09-03 05:59:19 UTC
ping Sebastian...
Comment 4 Sebastian Zazula 2009-09-03 13:09:24 UTC
Sorry for delay but i've got another problem... after compiling kernel, suspend stopped working completely and i couldn't test this patch. It only works on kernel from my distribution... I think it's sata related problem because the only change i made in config from this kernel is compiling sata emulation as ata directly into kernel, in my arch linux it uses initrd...
Comment 5 Sebastian Zazula 2009-09-03 13:10:41 UTC
Created attachment 22985 [details]
acpidump
Comment 6 ykzhao 2009-09-24 08:45:52 UTC
Hi, Rui
    From the comment #4 it seems that the suspend/resume can work on this box. So this bug can be marked as resolved.
    thanks.
Comment 7 Len Brown 2009-11-25 05:12:44 UTC
closing as unreproducible due to no response.
Please re-open if this is an issue w/ the latest kernel.

Note You need to log in before you can comment on or make changes to this bug.