Bug 14006 - (AtanasKamburov) suspend/hibernate issues with Thinkpad X31
(AtanasKamburov)
suspend/hibernate issues with Thinkpad X31
Status: CLOSED UNREPRODUCIBLE
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2009-08-19 01:39 UTC by Atanas Kamburov
Modified: 2012-02-02 03:18 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.30.5
Tree: Mainline
Regression: Yes


Attachments
lspci (1.49 KB, text/plain)
2009-08-19 01:45 UTC, Atanas Kamburov
Details
dmesg (22.17 KB, text/plain)
2009-08-19 01:46 UTC, Atanas Kamburov
Details
kernel-2.6.30.5 .config (53.83 KB, text/plain)
2009-08-19 02:04 UTC, Atanas Kamburov
Details
dmesg 2.6.28 (22.50 KB, application/octet-stream)
2009-10-01 13:14 UTC, Atanas Kamburov
Details

Description Atanas Kamburov 2009-08-19 01:39:16 UTC
Hi,  suspend/hibernate stopped working on my IBM Thinkpad X31 after kernel 2.6.27.  E.g., after I do "echo disk > /sys/power/state", the screen becomes black with a blinking cursor in the top left corner, then switches back to X but I cannot execute any commands, guess the HDD is turned off. In the console where I types in the command, the error message is: "/bin/echo: write error: Input/output error".  I have tried a lot of stuff, also upgraded the BIOS, but nothing helped. The gentoo-mobile guys have not helped so far, a bug report is also posted by me here: http://bugs.gentoo.org/show_bug.cgi?id=270515 . Before posting this bug, I reproduced it with vanilla sources 2.6.30.5; however, it is reproducible with all kernel versions post-2.6.27 I have tried.
Comment 1 Atanas Kamburov 2009-08-19 01:45:47 UTC
Created attachment 22766 [details]
lspci
Comment 2 Atanas Kamburov 2009-08-19 01:46:13 UTC
Created attachment 22767 [details]
dmesg
Comment 3 Atanas Kamburov 2009-08-19 02:03:10 UTC
oh, and btw, the results are the same if I try to suspend/hibernate with stopped X.
I would be happy to provide more info if needed, or try your suggestions.
Comment 4 Atanas Kamburov 2009-08-19 02:04:29 UTC
Created attachment 22768 [details]
kernel-2.6.30.5  .config
Comment 5 ykzhao 2009-09-21 03:34:38 UTC
Hi, Atanas
    Do you mean that you can't execute the command of "echo disk > /sys/power/sate" under console mode?
    Please double check it again and confirm whether you have the permission to access it.
    thanks.
Comment 6 Atanas Kamburov 2009-09-21 08:57:53 UTC
I can execute the command "echo disk >
/sys/power/sate" as root, and hibernate begins, but the problem is that after writing some stuff to the disk from the ram (probably) the laptop just hangs.
Comment 7 ykzhao 2009-09-29 06:42:38 UTC
From the dmesg log in comment #2 it seems that there exist the following warning message:
   >hda: hda1 hda2 hda3
   >hda: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
   >hda: task_no_data_intr: error=0x04 { DriveStatusError }
   >hda: possibly failed opcode: 0xea
   >hda: wcache flush failed!

   Do you have an opportunity to try another disk and see whether the issue still exists?
   Thanks.
Comment 8 Atanas Kamburov 2009-09-29 10:20:29 UTC
Hi Yakui,

thanks for your attention to my hibernation problems.
You are right, I get this error (task_no_data_intr) with newer kernels but not with the kernel that hibernation works with (2.6.27). Unfortunately, I cannot try another disk. If the problem were because of the disk, then hibernation shouldn't work with 2.6.27, I think...

Btw., I just realized that comment #6 is actually wrong (sorry, I had played around with a lot of kernels and options so I was confused). The result from the command "echo disk > /sys/power/sate" with kernel 2.6.31 is that I get the message "bash: echo: write error: Input/output error" and the laptop hangs (I cannot execute any command or open any window, but I can move the mouse pointer) - I think the disk stops spinning then.  The same command ("echo disk > /sys/power/sate") works with kernel 2.6.27.

Thanks, and please let me know if there is any more info that you need.
Comment 9 Rafael J. Wysocki 2009-09-29 18:38:22 UTC
Since the issue appears to be reproducible 100% of the time on your system, would it be possible to carry out a bisection of commits between 2.6.27 and the first failing kernel?
Comment 10 Atanas Kamburov 2009-09-29 22:28:44 UTC
thanks for the suggestion.  I would be happy to do that.  I understand that what you mean is to take a succession of kernels from 2.6.27.1 and compile and test every version after that.  Since my OS is gentoo linux, I suppose what I would have to do is install all relevant kernels from here http://gentoo-portage.com/sys-kernel/vanilla-sources and do "make oldconfig" each time.
Please let me know if you meant something else.
Comment 11 Atanas Kamburov 2009-09-30 12:43:40 UTC
(In reply to comment #9)
> Since the issue appears to be reproducible 100% of the time on your system,
> would it be possible to carry out a bisection of commits between 2.6.27 and the
> first failing kernel?

OK - I installed kernel 2.6.27.35 and "echo disk > /sys/power/sate" does what it should (hibernate) and then installed kernel 2.6.28 and "echo disk > /sys/power/sate" gives the error "bash: echo: write error: Input/output error" and does not hibernate, as described above.
Comment 12 Atanas Kamburov 2009-10-01 13:11:41 UTC
Oh, and something else that might be of importance.  With 2.6.28, I don't get the warning messages as in comment #7 (which I get e.g. with kernel 2.6.30.5), but instead I get the following message:  "thinkpad_acpi: acpi_bus_get_device(bay) failed: -19" during startup. So maybe the failing hibernate is not relatedto the warning messages from comment #7 after all...
I am attaching the dmesg with 2.6.28.
Comment 13 Atanas Kamburov 2009-10-01 13:14:22 UTC
Created attachment 23219 [details]
dmesg 2.6.28
Comment 14 Zhang Rui 2010-01-18 02:12:00 UTC
what about suspend? Does the system hang?

please run "echo mem > /sys/power/state; dmesg > dmesg-suspend" and see if you can get the log after the failure.
Comment 15 Zhang Rui 2010-01-18 02:13:31 UTC
And it would be great if you can verify if it works in 2.6.32.
Comment 16 Atanas Kamburov 2010-01-20 18:59:02 UTC
thanks for your interest in this bug.

suspend does not work:
"echo mem > /sys/power/state; dmesg > dmesg-suspend" shuts down the disk, on the console I get "bash: echo: write error: Input/output error" and the file dmesg-suspend is simply not there after a reboot (I have to do it with the power button).

sorry, I cannot try kernel 2.6.32 for now, since on boot I get an error message, something about the root filesystem not being able to mount read/write. This happens despite the fact that I used make oldconfig from 2.6.31 and left every new option with the default value. I guess this should be another bug report though.....
Comment 17 Zhang Rui 2012-01-18 01:52:16 UTC
It's great that kernel bugzilla is back.

can you please verify if the problem still exists in the latest upstream
kernel?
Comment 18 Atanas Kamburov 2012-01-19 11:03:07 UTC
Sorry, I cannot - I have sold the thinkpad... I guess the bug can be closed as it does not seem to be common, maybe it was just my hard disk making problems.
Comment 19 Zhang Rui 2012-02-02 03:18:44 UTC
Get it. Bug closed.

Note You need to log in before you can comment on or make changes to this bug.