Bug 13950 - Oops when USB Serial disconnected while in use
Oops when USB Serial disconnected while in use
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-08-09 22:51 UTC by Rafael J. Wysocki
Modified: 2009-10-02 21:24 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.31-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-08-09 22:51:43 UTC
Subject    : 2.6.31-rc5 regression: Oops when USB Serial disconnected while in use
Submitter  : Bruno Prémont <bonbons@linux-vserver.org>
Date       : 2009-08-08 17:47
References : http://marc.info/?l=linux-kernel&m=124975432900466&w=4
Notify-Also : Alan Stern <stern@rowland.harvard.edu>

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-08-18 21:17:34 UTC
On Tuesday 18 August 2009, Bruno Prémont wrote:
> 
> I just had a short look with 2.6.31-rc6, it crashes harder... once
> kernel did panic with general protection fault after reporting
>   tty_port_close_start: count=-1
> The second time id started output of an Oops but only half of the first
> line ever showed up on screen (Intel KMS).
> 
> Note: this was with just usbserial.ko and ftdi_sio.ko rebuilt with
> CONFIG_DEBUG_INFO=y in the hope to find out what did access a bad
> pointer. (make CONFIG_DEBUG_INFO=y drivers/usb/serial/$module.ko)
> 
> Will retry now with a fresh compile with CONFIG_DEBUG_INFO enabled for
> whole kernel and see if I can get better information, eventually
> switching to vesa framebuffer in case the partial output happens again.
> 
> This pretty much looks like unbalanced ref-count...
Comment 2 Rafael J. Wysocki 2009-08-30 22:30:12 UTC
Handled-By : Alan Stern <stern@rowland.harvard.edu>
Comment 3 Rafael J. Wysocki 2009-10-02 21:24:01 UTC
On Friday 02 October 2009, Bruno Prémont wrote:
> On Thu, 01 October 2009 "Rafael J. Wysocki" <rjw@sisk.pl> wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.30 and 2.6.31.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.30 and 2.6.31.  Please verify if it still
> > should be listed and let me know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13950
> > Subject	: Oops when USB Serial disconnected while in
> > use Submitter	: Bruno Prémont <bonbons@linux-vserver.org>
> > Date		: 2009-08-08 17:47 (55 days old)
> > References	: http://marc.info/?l=linux-kernel&m=124975432900466&w=4
> > Handled-By	: Alan Stern <stern@rowland.harvard.edu>
> 
> This has been adressed with following commits:
>   41bd34ddd7aa46dbc03b5bb33896e0fa8100fe7b
>   usb-serial: change referencing of port and serial structures
> 
>   f5b0953a89fa3407fb293cc54ead7d8feec489e4
>   usb-serial: put subroutines in logical order
> 
>   8bc2c1b2daf95029658868cb1427baea2da87139
>   usb-serial: change logic of serial lookups
> 
>   cc56cd0157753c04a987888a2f793803df661a40
>   usb-serial: acquire references when a new tty is installed
> 
>   7e29bb4b779f4f35385e6f21994758845bf14d23
>   usb-serial: fix termios initialization logic
> 
>   74556123e034c8337b69a3ebac2f3a5fc0a97032
>   usb-serial: rename subroutines
> 
>   ff8324df1187b7280e507c976777df76c73a1ef1
>   usb-serial: add missing tests and debug lines
> 
>   320348c8d5c9b591282633ddb8959b42f7fc7a1c
>   usb-serial: straighten out serial_open
> 
> They went into 2.6.32-rc1 and are probably queued for 2.6.31.2 stable.

Note You need to log in before you can comment on or make changes to this bug.