Bug 13944 - MD raid regression
MD raid regression
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: MD
All Linux
: P1 normal
Assigned To: io_md
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-08-09 21:55 UTC by Rafael J. Wysocki
Modified: 2009-08-19 22:48 UTC (History)
0 users

See Also:
Kernel Version: 2.6.31-rc5-git2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-08-09 21:55:35 UTC
Subject    : 2.6.31-rc5-git2 MD raid regression
Submitter  : Mike Snitzer <snitzer@redhat.com>
Date       : 2009-08-05 15:06
References : http://marc.info/?l=linux-kernel&m=124948481218857&w=4

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 449aad3e25358812c43afc60918c5ad3819488e7
Author: NeilBrown <neilb@suse.de>
Date:   Mon Aug 3 10:59:58 2009 +1000

    md: Use revalidate_disk to effect changes in size of device.

First-Bad-Commit : 449aad3e25358812c43afc60918c5ad3819488e7
Comment 1 Rafael J. Wysocki 2009-08-09 22:00:21 UTC
Handled-By : NeilBrown <neilb@suse.de>
Patch : http://patchwork.kernel.org/patch/39521/
Comment 2 Rafael J. Wysocki 2009-08-10 14:16:40 UTC
Ignore-Patch : http://patchwork.kernel.org/patch/39521/
Patch : http://patchwork.kernel.org/patch/40328/
Comment 3 Rafael J. Wysocki 2009-08-19 22:48:56 UTC
Fixed by commit c8c00a6915a2e3d10416e8bdd3138429beb96210 .

Note You need to log in before you can comment on or make changes to this bug.