Bug 13897 - PAT wc & vmap mapping count issue
PAT wc & vmap mapping count issue
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-08-02 21:09 UTC by Rafael J. Wysocki
Modified: 2009-08-09 23:42 UTC (History)
0 users

See Also:
Kernel Version: 2.6.30
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-08-02 21:09:30 UTC
Subject    : PAT wc & vmap mapping count issue ?
Submitter  : Jerome Glisse <glisse@freedesktop.org>
Date       : 2009-07-30 13:11
References : http://marc.info/?l=linux-kernel&m=124895237114605&w=4
Handled-By : "Pallipadi, Venkatesh" <venkatesh.pallipadi@intel.com>
Patch      : http://patchwork.kernel.org/patch/38436/

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 3869c4aa18835c8c61b44bd0f3ace36e9d3b5bd0
Author: venkatesh.pallipadi@intel.com <venkatesh.pallipadi@intel.com>
Date:   Thu Apr 9 14:26:50 2009 -0700

    x86, PAT: Changing memtype to WC ensuring no WB alias

    Signed-off-by: Venkatesh Pallipadi <venkatesh.pallipadi@intel.com>
    Signed-off-by: Suresh Siddha <suresh.b.siddha@intel.com>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>

First-Bad-Commit : 3869c4aa18835c8c61b44bd0f3ace36e9d3b5bd0
Comment 1 Rafael J. Wysocki 2009-08-09 23:42:58 UTC
Fixed by commit bdc6340f4eb68295b1e7c0ade2356b56dca93d93 .

Note You need to log in before you can comment on or make changes to this bug.