Bug 13894 - intermittent hibernation problem
intermittent hibernation problem
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 13615
  Show dependency treegraph
 
Reported: 2009-08-02 20:06 UTC by Rafael J. Wysocki
Modified: 2009-10-19 14:15 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.31-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-08-02 20:06:25 UTC
Subject    : [linux-pm] intermittent suspend problem
Submitter  : Ferenc Wagner <wferi@niif.hu>
Date       : 2009-07-30 13:29
References : https://lists.linux-foundation.org/pipermail/linux-pm/2009-July/022095.html

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 ykzhao 2009-08-03 01:03:51 UTC
Hi, Ferenc
    Will you please double check it again and see whether the issue can be reproduced?
    Thanks.
Comment 3 Ferenc Wágner 2009-08-22 20:15:09 UTC
Well.  Too bad I didn't get notification mails from Bugzilla...  Anyway: I hit this issue again running 429966b8f644dda2afddb4f834a944e9b46a7645 (that is, a little before 2.6.31-rc7.  Actually, I forgot to git-describe before pulling right now, but that's HEAD@{1} in the reflog, and seems to make sense.)

This time, suspend to disk neglected to switch off my laptop, so I switched it off and on manually, resumed, then did a proper poweroff (initiated by hitting the power switch). The shutdown went OK, but it again did not switch off the computer:

Mounting root filesystem read-only...done
Will now halt
[48341.851097] Shutdown: hda

And everything stopped there.  After checking out d5194decd0a6f792b2789eebd4ddf022a248f655, I have to say I don't expect it to help, as my Celeron M isn't particularly cooperative, so:
# CONFIG_CPU_FREQ is not set.
CONFIG_CPU_IDLE=y
CONFIG_CPU_IDLE_GOV_LADDER=y
CONFIG_CPU_IDLE_GOV_MENU=y

Yakui, I also thought it may be related to https://bugs.freedesktop.org/show_bug.cgi?id=22126, but I couldn't prove it.  At least, that freeze is 100% reproducible (I've tested it with the same kernel), but this is totally stochastic, happens once a week or so, after dozens of suspends to RAM and quite some suspends to disk.  And if in the initramfs, after loading i915 with modeset=1, I say "poweroff" instead of "echo mem >/sys/power/state" then my system powers off in an instant, while it locks up all the time otherwise.
Comment 4 Ferenc Wágner 2009-10-18 10:43:31 UTC
It happened again, this time on 2.6.32-rc5. 2.6.31 final never showed this issue, 2.6.32-rc4 neither (though I was using that for a short period only, and the issue isn't reproducible, so it doesn't mean much). Also, this time STR worked after power cycling (and successfully resuming) the machine.

Also, I upgraded the BIOS a couple of days ago, in hope to get STR with KMS work, but it didn't help that. Still, it may be another factor worth mentioning.
Comment 5 Ferenc Wágner 2009-10-19 14:15:14 UTC
In the last few days s2disk froze twice after printing "Snapshotting system". I've never seen such a thing under any other kernel but 2.6.32-rc5.

Note You need to log in before you can comment on or make changes to this bug.