Bug 13881 - radeon KMS on Mobility Radeon X1200 (RS690M) unable to find EDID -> blank screen until X starts
radeon KMS on Mobility Radeon X1200 (RS690M) unable to find EDID -> blank scr...
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-30 16:48 UTC by Matthias Tingelhoff
Modified: 2009-07-31 20:32 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.31-rc4-git5
Tree: Mainline
Regression: No


Attachments
dmesg output when booting with KMS enabled (38.47 KB, text/plain)
2009-07-30 16:48 UTC, Matthias Tingelhoff
Details
Xorg.0.log when using KMS (50.83 KB, text/plain)
2009-07-30 16:49 UTC, Matthias Tingelhoff
Details
output of ddcprobe (621 bytes, text/plain)
2009-07-30 16:51 UTC, Matthias Tingelhoff
Details

Description Matthias Tingelhoff 2009-07-30 16:48:22 UTC
Created attachment 22544 [details]
dmesg output when booting with KMS enabled

I have an HP Compaq 6715s Notebook with an Mobility Radeon X1200 (RS690M) GPU and wanted to try KMS, but the screen simply goes blank, until X starts up which is actualy able to set the correct mode and works then.
The dmesg output shows that its unable to get the EDID.

This was also the case with pre-rc4-git5 kernels, but now the system sometimes freeze during boot, because of the blank screen I am unable to tell you any error messages for that case.

The attached dmesg log was made after a "successful" boot with 2.6.31-rc4-git5.
I also attach Xorg.0.log and the output of ddcprobe, if you need any more information just let me know, of course.
Comment 1 Matthias Tingelhoff 2009-07-30 16:49:53 UTC
Created attachment 22545 [details]
Xorg.0.log when using KMS
Comment 2 Matthias Tingelhoff 2009-07-30 16:51:57 UTC
Created attachment 22546 [details]
output of ddcprobe
Comment 3 Alex Deucher 2009-07-30 16:57:17 UTC
Do you have fbcon loaded?  Without that, you won't get a console on the radeon drm fb device.
Comment 4 Matthias Tingelhoff 2009-07-30 17:39:16 UTC
... oh no .... thats it !

fbcon was build as an module, as soon its loaded via modprobe or built into the kernel, it works !

But the boot-freeze problem is still there, but now I can see where it hangs:

input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input0


Dont see anything wrong in the messages above that, but it freezes there, still able to reboot via CTRL+ALT+DEL.

This might be a different bug, but with radeon.modeset=0, this doesn't happen.
Comment 5 Matthias Tingelhoff 2009-07-31 00:08:16 UTC
To provide some "useful" information, I've bisected my problem:

# bad: [e4c6f8bed01f9f9a5c607bd689bf67e7b8a36bd8] hugetlbfs: fix i_blocks accounting
git bisect bad e4c6f8bed01f9f9a5c607bd689bf67e7b8a36bd8
# good: [659098141d02eb8e3545be8969d262e02d2f3f98] rtc: mark if rtc-cmos drivers were successfully registered
git bisect good 659098141d02eb8e3545be8969d262e02d2f3f98


As soon that i_blocks accounting stuff is applied, my system hangs during boot with KMS enabled. Without KMS, it boots fine.

Hope that helps !
Comment 6 Dave Airlie 2009-07-31 00:27:34 UTC
Hmm this might be due to a WC bug that we've just noticed

[PATCH] x86: Fix set_memory_wc related corruption

is on lkml at the moment hopefully it might help.
Comment 7 Matthias Tingelhoff 2009-07-31 02:04:19 UTC
Tried that patch from LKML and ..... it helps :)
Wonderful !

Thanx for your time and help !

Note You need to log in before you can comment on or make changes to this bug.