Bug 13880 - (freezes) repeated freezes after bios update - Toshiba Satellite L300
(freezes)
repeated freezes after bios update - Toshiba Satellite L300
Status: RESOLVED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2009-07-30 15:39 UTC by Thoralf Dassler
Modified: 2013-04-09 06:23 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.30.2
Tree: Mainline
Regression: No


Attachments
dmesg with define DEBUG on (30.86 KB, application/octet-stream)
2009-08-04 12:32 UTC, Thoralf Dassler
Details
dmesg_ACPI_DEBUG_ON (30.95 KB, application/octet-stream)
2009-08-13 14:04 UTC, Thoralf Dassler
Details
acpidump (179.35 KB, application/octet-stream)
2009-08-13 14:05 UTC, Thoralf Dassler
Details

Description Thoralf Dassler 2009-07-30 15:39:19 UTC
I am out of ideas and a bit desperate really.

The laptop is a Toshiba Satellite L300 with an Insyde H20 Bios. Until I updated the Bios from 1.60 to 1.80, I had no problems. Now, to even get X going, I needed kernel 2.6.30.x.

Symptoms:
---------
1) Non-random crashes: when the screen saver is on, X does come back but keyboard and mouse immediately freeze. Not using the intel driver from X and instead using the generic vesa does not change a thing.
2) Random crashes: when this happens, the last key that was pressed gets stuck. If I am lucky and have an editor or office open, I see the last
pressed key printed endlessly. After the key got stuck the mouse still moves for a while without click function. Still a little while later the mouse freezes and the hole system stops responding.

I have turned debugging output in the kernel for ACPI and USB, but I cannot see anything suspicious in the log after reboot. Nothing suspicious.

There is, however, this:

ACPI: EC: GPE storm detected, transactions will use polling mode
ACPI: EC: missing confirmations, switch off interrupt mode

but since I have the very same on my other laptop which runs rock solidly, I do not think that the ACPI messages cause the trouble on the L300.
Comment 1 Andrew Morton 2009-07-30 21:28:45 UTC
Not an IA64 bug :)

I'll reassign this to acpi, thanks.
Comment 2 Thoralf Dassler 2009-07-31 08:51:59 UTC
Thanks.
Comment 3 Thoralf Dassler 2009-07-31 10:32:49 UTC
Because I get the ACPI warnings on my other Laptop which does not freeze. shoud we not discout the ACPI here? If we do this would the freezes not be an IA64 issue?
Comment 4 Alexey Starikovskiy 2009-08-02 04:49:55 UTC
IA64 is Intel Itanium. You don't have it in your notebook, this is what Andrew tried to say :)
Could you please try to uncomment "#define DEBUG" in drivers/acpi/ec.c and attach dmesg here? if it does not contain beginning of boot, please attach /var/log/messages instead (the one _containing_ "storm detected" message).
Comment 5 Thoralf Dassler 2009-08-04 12:32:11 UTC
Created attachment 22603 [details]
dmesg with define DEBUG on
Comment 6 Thoralf Dassler 2009-08-04 12:32:49 UTC
Please see dmesg as requested. Except for the first two lines after reboot, all other lines are there.
Comment 7 Thoralf Dassler 2009-08-06 12:15:08 UTC
Do we need CONFIG_ACPI_DEBUG=y as well? I have turned it off again since I first reported the bug.
Comment 8 Len Brown 2009-08-13 03:26:47 UTC
nothing here suggests to me that this hang is ACPI related,
but please attach the output from acpidump for reference.

after your BIOS update did you go into SETUP and select the defaults?
Comment 9 Thoralf Dassler 2009-08-13 14:04:24 UTC
Created attachment 22707 [details]
dmesg_ACPI_DEBUG_ON

After the update I did chnge the BIOS values to default and booted into Linux. Same freezes. The I went back into the BIOS and turned on what I wanted, again, same freezes.
Comment 10 Thoralf Dassler 2009-08-13 14:05:05 UTC
Created attachment 22708 [details]
acpidump
Comment 11 Zhang Rui 2009-08-17 05:52:24 UTC
does the problem still exists if using boot option "idle=poll"?
Comment 12 Thoralf Dassler 2009-08-17 08:13:59 UTC
Currently traveling, will try when I am back next week.
Comment 13 Thoralf Dassler 2009-08-26 14:04:57 UTC
I have tried boot option 'idle=poll' and the freezes still occur. I have contacted Toshiba. Because they insist this is a hardware fault I will ask them to collect the laptop for repair.
Comment 14 ykzhao 2009-08-26 14:25:00 UTC
Hi, Thoralf
    Will you please confirm whether it still freeze under console mode?
    Will you please add the boot option of "nolapic_timer" and see whether it still freezes?
    Thanks.
Comment 15 Thoralf Dassler 2009-08-26 16:08:25 UTC
Will do before I phone Toshiba.
Comment 16 Thoralf Dassler 2009-08-28 10:44:53 UTC
nolapic_timer didn't help.

Now I am testing without X. This is going take some time because I gave the laptop something to do in console mode and will leave it for a few days. I left the laptop in console mode over night with nothing to do and this morning it was still responding normally.
Comment 17 Thoralf Dassler 2009-09-02 14:53:50 UTC
1) Testing without X for 3 days continuous did not freeze the computer.

2) I updated to Slackware 13.0, which, according to its official announcement, comes with an updated xorg. After 2 days, the Laptop has not frozen.

Should we close the bug?
Comment 18 Zhang Rui 2009-09-03 06:38:42 UTC
I don't know.
As the freeze happens only when X is started, re-assign this to video category
Comment 19 Thoralf Dassler 2009-09-03 09:14:17 UTC
Thanks.

Update: is is 3 days now that the laptop has not frozen while running X. This looks as though the xorg update that came with the latest release of my Distro has done the trick.
Comment 20 Zhang Rui 2009-09-03 09:22:13 UTC
or you can close this bug and open a bug at https://bugs.freedesktop.org/. :)
Comment 21 Gordon Jin 2009-09-18 02:53:40 UTC
closing. 

If you see new issues, please file new bugs according to
http://www.intellinuxgraphics.org/how_to_report_bug.html.
Comment 22 Thoralf Dassler 2009-10-08 15:56:51 UTC
Update: Toshiba have released another BIOS update. Now the video driver works again as it did before the previous BIOS update.

Note You need to log in before you can comment on or make changes to this bug.