Bug 13876 - [x86_32, 2.6.30, reiserfs, reiser3, bug, regression] kernel oopsed while Sarg was running
Summary: [x86_32, 2.6.30, reiserfs, reiser3, bug, regression] kernel oopsed while Sarg...
Status: RESOLVED CODE_FIX
Alias: None
Product: File System
Classification: Unclassified
Component: ReiserFS (show other bugs)
Hardware: All Linux
: P1 high
Assignee: ReiseFS developers team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-30 11:36 UTC by Igor M Podlesny
Modified: 2009-11-23 09:44 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.30
Tree: Mainline
Regression: Yes


Attachments
partial dmesg output (2.13 KB, text/plain)
2009-07-30 11:36 UTC, Igor M Podlesny
Details
Screen photo taken before hard rebooting the box (137.52 KB, image/jpeg)
2009-07-30 12:23 UTC, Igor M Podlesny
Details

Description Igor M Podlesny 2009-07-30 11:36:30 UTC
Created attachment 22537 [details]
partial dmesg output

(Sarg is Squid statistic analyzer, giving quite valuable both disk and CPU load.)

dmesg is in the attachment. Unfortunately, it's not complete cause the kernel's failure made it impossible to log in to the comp where it occurred. Possibly, it completely remains in the system log files, and I hope since the comp will get rebooted (it's a remote one for me), I'll be able to find the logs and rest of the filesystem... ergh... intact.
Comment 1 Igor M Podlesny 2009-07-30 12:23:11 UTC
Created attachment 22538 [details]
Screen photo taken before hard rebooting the box

Hopefully, it gives the missing info — no log file records regarding that issue survived.
Comment 2 Roland Kletzing 2009-08-20 14:31:01 UTC
could you please provide the mount options for your reiserfs filesystems ?
Comment 3 Igor M Podlesny 2009-08-20 14:51:40 UTC
(In reply to comment #2)

(rw,relatime,data=journal)
Comment 4 Roland Kletzing 2009-08-20 15:30:50 UTC
ah, we have possibly a duplicate here - see http://bugzilla.kernel.org/show_bug.cgi?id=13556

can you try if mounting your reiserfs filesystems without data=journal fixes the problem ?
Comment 5 Igor M Podlesny 2009-08-20 15:36:57 UTC
(In reply to comment #4)
> ah, we have possibly a duplicate here - see

	Well, quite likely we do, yeah.

> can you try if mounting your reiserfs filesystems without data=journal fixes
> the problem ?

	Dunno when... so feel free to mark this bug-entry as a dup.
Comment 6 Linus Torvalds 2009-08-21 19:56:26 UTC
Igor, can you try the patch I just added in that bugzilla entry 13556?
Comment 7 Roland Kletzing 2009-08-22 08:56:04 UTC
you can also try latest .31-rc7 kernel from kernel.org
Comment 8 Roland Kletzing 2009-11-21 00:06:46 UTC
Igor, can you try latest kernel and give some feedback as this ticket would be closed due to missing response?

i'm quite sure this/your bug is fixed. 

if your bug is different, then it`s the last chance to tell about that.
Comment 9 Igor M Podlesny 2009-11-23 09:44:59 UTC
> Igor, can you try latest kernel

Roland, that comp. isn't mine; it has been running 2.6.27.something happily for quite a long time now and its users are careless. I don't think it'd be a good idea to tell'em "guys, kernel devs would like to give your box another crash test, wouldn't ya mind, ugh?". :-)

P. S. I tried reproducing this problem inside VirtualBox but failed -- 2.6.30 inside it runs just ok. In case I'll have a chance to meet that bug I'll do my best reporting it. Let me mark this ticket as resolved.

Note You need to log in before you can comment on or make changes to this bug.