Bug 13874 - kenal panic on addition of xfx nvidia gts250 512mb on 946giz motherboard
kenal panic on addition of xfx nvidia gts250 512mb on 946giz motherboard
Status: CLOSED OBSOLETE
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 high
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-30 07:57 UTC by ankurbajaj9
Modified: 2012-06-13 14:30 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.x
Tree: Mainline
Regression: No


Attachments

Description ankurbajaj9 2009-07-30 07:57:49 UTC
I have tried many linux flavors from debian lenny, fedora , slackware , mandriva ,ubuntu etc but i have not been able to boot from a single live cd or from the installed media after installation.
There seems to be memory clash between the graphics card and kernel for the bios memory
I used to use linux without any errors prior to installation of the graphics card
Comment 1 Andrew Morton 2009-08-03 20:42:53 UTC
We'll need some information about the panic, please.  Are you able to set up a serial console and use early_printk?  Or just set the display in 50-row mode and take a digital photograph?
Comment 2 ankurbajaj9 2009-08-04 11:40:20 UTC
http://www.youtube.com/watch?v=fYiaL3RlDNo

video of the panic in case of mandriva 2009.1 spring

http://www.linuxquestions.org/questions/showthread.php?t=737540

you will get some details here too
Comment 3 Andrew Morton 2009-08-04 17:05:17 UTC
OK, thanks.  Pause the video at 0:30 and one sees an oops in ext3_handle_error().

I'll reassign the report.

I expect 2.6.30 will do the same thing :(
Comment 4 Andrew Morton 2009-08-04 17:07:02 UTC
CC Jan.
Comment 5 Jan Kara 2009-08-04 20:17:05 UTC
Well, the machine obviously has some serious problem. Just before the oops, there's a message "bad entry in directory #565751: rec_len is smaller than minimal" and then dump showing all entries are zero. This is quite early during boot (udev has just started, we loaded keyboard maps and then oopsed). Given this is some live DVD I believe some memory corruption is happening. The oops is probably on dereferencing EXT3_SB(sb)->s_es which again shouldn't pose a problem.

I've read the details you've posted to the forum referenced above and you write there about a memory conflict of your Nvidia graphics card and "lots of memory errors during the boot". So probably that should be resolved first. Sadly I cannot see the relevant message in the recorded video to judge who should have a look into this. So first, try booting with nosplash,vga=normal boot options and record that boot on your camera. Hopefully that will contain all the relevant error messages and we can then investigate further.
Comment 6 ankurbajaj9 2009-08-05 14:34:18 UTC
have uploaded two more videos hope they help

http://www.youtube.com/watch?v=vPkaOtm7crk

http://www.youtube.com/watch?v=EvFQlk957vs
Comment 7 Jan Kara 2009-08-05 17:06:45 UTC
Hmm, I've looked at those videos. The first just confirms its some really lowlevel problem - we oopsed quite early while trying to get a free page. I didn't find any suspicious message in the second one... There's just something about "stolen memory". Probably someone with lowlevel HW/BIOS knowledge should look into this memory corruption. It's definitely not fs related... Andrew, could you please reassign? I don't seem to have enough rights.
Comment 8 Andrew Morton 2009-08-06 23:25:35 UTC
I don't know where to reassign it, really.  Where's the bug?

A can randomly punt it in the x86_64 direction, but I suspect the hardware is broken.

Does _any_ version of the linux kernel run properly on that particular machine?
Comment 9 ankurbajaj9 2009-08-07 08:13:01 UTC
every linux used to work fine till i installed the graphics card after that none worked

i had old dream linux 2.2 live cd which is the only live cd that booted on my system. 2.6.18.1 was the kernel version .....but the video support was bad so i did not install
Comment 10 ankurbajaj9 2009-10-11 04:09:47 UTC
any progress guys
im tired of winodows
Comment 11 ankurbajaj9 2009-11-15 06:55:25 UTC
my memtest86+ test was a success no errors of any sort and even my video ram stress test was a success
my system was able to boot opensolaris but i didnt install it
So hardware does not seem to be a problem here as xp , vista or win 7 dont give me any problem.
Comment 12 Jan Kara 2009-11-16 10:21:56 UTC
Yeah, I believe it's not a problem in your memory as such but rather in a way how we handle your video card (the card might also have a quirk that Windows handle just fine but Linux ends up corrupting memory because of it). If some x86_64 guys had a look at this, they could probably say more than my uneducated guessing ;).
Comment 13 ankurbajaj9 2009-11-18 17:46:16 UTC
removed my gfx card installed the linux and booted it successfully!!!!!

Note You need to log in before you can comment on or make changes to this bug.