Bug 13872 - cpufreq bug (null pointer dereference)
cpufreq bug (null pointer dereference)
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: cpufreq
All Linux
: P1 normal
Assigned To: cpufreq
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-07-29 21:53 UTC by Rafael J. Wysocki
Modified: 2009-08-05 11:40 UTC (History)
0 users

See Also:
Kernel Version: 2.6.31-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-07-29 21:53:27 UTC
Subject    : 2.6.31-rc3 cpufreq bug (null pointer dereference)
Submitter  : Christophe Lermytte <christophe.lermytte@thomson.net>
Date       : 2009-07-21 22:07
References : http://marc.info/?l=linux-kernel&m=124820689011112&w=4
Handled-By : "Pallipadi, Venkatesh" <venkatesh.pallipadi@intel.com>
Patch      : http://patchwork.kernel.org/patch/38229/

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit ee88415caf736b89500f16e0a545614541a45005
Author: venkatesh.pallipadi@intel.com <venkatesh.pallipadi@intel.com>
Date:   Thu Jul 2 17:08:33 2009 -0700

    [CPUFREQ] Cleanup locking in conservative governor

    Signed-off-by: Venkatesh Pallipadi <venkatesh.pallipadi@intel.com>
    Signed-off-by: Dave Jones <davej@redhat.com>

First-Bad-Commit : ee88415caf736b89500f16e0a545614541a45005

Note You need to log in before you can comment on or make changes to this bug.