Bug 1385 - crash on boot on Compaq N620c with 2.6.0-test8
crash on boot on Compaq N620c with 2.6.0-test8
Status: REJECTED DUPLICATE of bug 1341
Product: ACPI
Classification: Unclassified
Component: Config-Other
i386 Linux
: P2 high
Assigned To: Len Brown
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-19 19:07 UTC by Aron Griffis
Modified: 2004-03-04 12:23 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.0-test8
Tree: Mainline
Regression: ---


Attachments
patch for reference count problem (3.39 KB, patch)
2003-10-20 01:38 UTC, Shaohua
Details | Diff

Description Aron Griffis 2003-10-19 19:07:06 UTC
Distribution: Gentoo (but using sources from kernel.org)
Hardware Environment: Compaq N620c
Software Environment: gcc-3.2.3, binutils-2.14.90.0.6
Problem Description: crash on boot

Steps to reproduce:
1. build 2.6.0-test8
2. boot on Compaq N620c
3. collect the debugging information on serial console ;-)

Booting 'vanilla-sources-2.6.0-test8'
                                                                               
root (hd0,0)
 Filesystem type is reiserfs, partition type 0x83
kernel (hd0,0)/boot/bzImage-2.6.0-test8 root=/dev/hda3 hdc=ide-scsi
console=ttyS0,57600n8
   [Linux-bzImage, setup=0x1400, size=0x18ba6f]
                                                                               
Linux version 2.6.0-test8 (root@mustard) (gcc version 3.3.1 20030916 (Gentoo
Linux 3.3.1-r4, propolice)) #3 Mon Oct 20 05:25:12 EDT 2003
Video mode to be used for restore is f00
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000e0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001ffd0000 (usable)
 BIOS-e820: 000000001ffd0000 - 000000001fff0c00 (reserved)
 BIOS-e820: 000000001fff0c00 - 000000001fffc000 (ACPI NVS)
 BIOS-e820: 000000001fffc000 - 0000000020000000 (reserved)
511MB LOWMEM available.
On node 0 totalpages: 131024
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 126928 pages, LIFO batch:16
  HighMem zone: 0 pages, LIFO batch:1
DMI 2.3 present.
ACPI: RSDP (v000 COMPAQ                                    ) @ 0x000f9970
ACPI: RSDT (v001 COMPAQ CPQ0058  0x02050320 CPQ  0x00000001) @ 0x1fff0c84
ACPI: FADT (v002 COMPAQ CPQ0058  0x00000002 CPQ  0x00000001) @ 0x1fff0c00
ACPI: SSDT (v001 COMPAQ  CPQGysr 0x00001001 MSFT 0x0100000e) @ 0x1fff7545
ACPI: DSDT (v001 COMPAQ    N620c 0x00010000 MSFT 0x0100000e) @ 0x00000000
Building zonelist for node : 0
Kernel command line: root=/dev/hda3 hdc=ide-scsi console=ttyS0,57600n8
ide_setup: hdc=ide-scsi
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
Initializing CPU#0
PID hash table entries: 2048 (order 11: 16384 bytes)
Detected 1599.078 MHz processor.
Console: colour VGA+ 80x25
Memory: 514556k/524096k available (2391k kernel code, 8788k reserved, 802k data,
152k init, 0k highmem)
Calibrating delay loop... 3162.11 BogoMIPS
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 1024K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: Intel(R) Pentium(R) M processor 1600MHz stepping 05
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
enabled ExtINT on CPU#0
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 1598.0400 MHz.
..... host bus clock speed is 99.0900 MHz.
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xf031f, last bus=4
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20031002
 tbxface-0117 [03] acpi_load_tables      : ACPI Tables successfully acquired
Parsing all Control
Methods:..........................................................................................................................................................................................................................................................................................
Table [DSDT](id F005) - 841 Objects with 76 Devices 282 Methods 26 Regions
Parsing all Control Methods:....
Table [SSDT](id F003) - 9 Objects with 0 Devices 4 Methods 0 Regions
ACPI Namespace successfully loaded at root c046683c
evxfevnt-0093 [04] acpi_enable           : Transition to ACPI mode successful
evgpeblk-0748 [06] ev_create_gpe_block   : GPE 00 to 31 [_GPE] 4 regs at
0000000000001028 on int 9
evgpeblk-0221 [08] ev_save_method_info   : Unknown GPE method type: C163 (name
not of form _Lnn or _Enn)
evgpeblk-0221 [08] ev_save_method_info   : Unknown GPE method type: C1EF (name
not of form _Lnn or _Enn)
Completing Region/Field/Buffer/Package
initialization:....................................................................................................................
Initialized 25/26 Regions 0/0 Fields 27/27 Buffers 64/64 Packages (858 nodes)
Executing all Device _STA and_INI
methods:.............................................................................
77 Devices found containing: 77 _STA, 8 _INI methods
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
dsopcode-0526 [19] ds_init_buffer_field  : <1>Unable to handle kernel NULL
pointer dereference at virtual address 00000004
 printing eip:
c0224719
*pde = 00000000
Oops: 0000 [#1]
CPU:    0
EIP:    0060:[<c0224719>]    Not tainted
EFLAGS: 00010213
EIP is at vsnprintf+0x319/0x450
eax: 00000004   ebx: 0000000a   ecx: 00000004   edx: 00000003
esi: c0466347   edi: 00000000   ebp: dff79ac4   esp: dff79a8c
ds: 007b   es: 007b   ss: 0068
Process swapper (pid: 1, threadinfo=dff78000 task=dff6f8c0)
Stack: dff79ad4 ffffffff 00000570 00000000 0000000a fffffff8 00000003 00000002
       00000004 00000004 ffffffff 00000001 dff79b40 c1528e68 dff79adc c02248a8
       c0466320 3fb99ce0 c0396c0a dff79b38 dff79af0 c022c523 c0466320 c0396be0
Call Trace:
 [<c02248a8>] vsprintf+0x28/0x30
 [<c022c523>] acpi_os_vprintf+0x13/0x2a
 [<c024ebc8>] acpi_ut_debug_print+0x91/0x98
 [<c022f037>] acpi_ds_init_buffer_field+0x17a/0x1ff
 [<c022f211>] acpi_ds_eval_buffer_field_operands+0x155/0x173
 [<c022fddb>] acpi_ds_exec_end_op+0x233/0x414
 [<c0246937>] acpi_ps_parse_loop+0x736/0xb18
 [<c024ed1b>] acpi_ut_status_exit+0x49/0x59
 [<c0230757>] acpi_ds_call_control_method+0x227/0x250
 [<c0232a56>] acpi_ds_get_current_walk_state+0x3e/0x46
 [<c0246dd9>] acpi_ps_parse_aml+0xc0/0x24f
 [<c0247af3>] acpi_psx_execute+0x213/0x290
 [<c0242f91>] acpi_ns_execute_control_method+0xd4/0xf1
 [<c0242e7f>] acpi_ns_evaluate_by_handle+0xcc/0x10a
 [<c0242c28>] acpi_ns_evaluate_relative+0x12c/0x178
 [<c024ed1b>] acpi_ut_status_exit+0x49/0x59
 [<c024ef58>] acpi_ut_evaluate_object+0x3c/0x189
 [<c024b3c1>] acpi_rs_get_crs_method_data+0x3f/0x7b
 [<c0249644>] acpi_get_current_resources+0x6e/0x86
 [<c024ec20>] acpi_ut_trace+0x29/0x2b
 [<c0255014>] acpi_pci_evaluate_crs+0x49/0xa6
 [<c0255233>] acpi_pci_root_add+0x1c2/0x2ae
 [<c025862c>] acpi_bus_driver_init+0x82/0x131
 [<c0258a58>] acpi_bus_find_driver+0x91/0xe4
 [<c0258faf>] acpi_bus_add+0x188/0x1ca
 [<c0259122>] acpi_bus_scan+0x131/0x18f
 [<c0434e8e>] acpi_scan_init+0x89/0xbb
 [<c042281b>] do_initcalls+0x2b/0xa0
 [<c0130c32>] init_workqueues+0x12/0x30
 [<c01050d5>] init+0x35/0x140
 [<c01050a0>] init+0x0/0x140
 [<c01082b9>] kernel_thread_helper+0x5/0xc
                                           
Code: 80 38 00 74 07 40 4a 83 fa ff 75 f4 29 c8 83 e7 10 89 c3 75
 <0>Kernel panic: Attempted to kill init!
Comment 1 Shaohua 2003-10-20 01:38:49 UTC
Created attachment 1111 [details]
patch for reference count problem

please try this patch. if it can't help, please attach acpidmp.
Comment 2 Shaohua 2003-10-30 21:05:43 UTC
it's a regresion, now has been reverted in 2.4-pre9. can you it? Thanks.
Comment 3 Len Brown 2003-10-31 09:38:29 UTC
I believe that this is the same prink bug seen in bug #1341 
 
Please re-open if disabling CONFIG_ACPI_DEBUG 
or the patch in that bug report do not address the problem. 
 
thanks 
-Len 
 

*** This bug has been marked as a duplicate of 1341 ***

Note You need to log in before you can comment on or make changes to this bug.