Bug 13846 - LEDs switched off permanently by power saving with rt61pci driver
LEDs switched off permanently by power saving with rt61pci driver
Status: CLOSED DOCUMENTED
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-07-26 22:18 UTC by Rafael J. Wysocki
Modified: 2009-08-10 14:05 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.31-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-07-26 22:18:29 UTC
Subject    : 2.6.31-rc2: Possible regression in rt61pci driver
Submitter  : Chris Clayton <chris2553@googlemail.com>
Date       : 2009-07-13 8:27
References : http://marc.info/?l=linux-kernel&m=124747418828398&w=4

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-07-27 22:53:44 UTC
On Monday 27 July 2009, Chris Clayton wrote:
> 2009/7/26 Rafael J. Wysocki <rjw@sisk.pl>:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.30.  Please verify if it still should be listed and let me know
> > (either way).
> >
> 
> This bug should remain open, although we are, I think, getting closer
> to the cause, which seems to be related to some interaction between
> the rt61 driver and mac80211 power saving.
> 
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=13846
> > Subject         : Possible regression in rt61pci driver
> > Submitter       : Chris Clayton <chris2553@googlemail.com>
> > Date            : 2009-07-13 8:27 (14 days old)
> > References      : http://marc.info/?l=linux-kernel&m=124747418828398&w=4
Comment 2 Rafael J. Wysocki 2009-08-03 19:18:58 UTC
On Monday 03 August 2009, Chris Clayton wrote:
> Hi Rafael,
> 
> On Sunday 02 August 2009, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.30.  Please verify if it still should be listed and let me know
> > (either way).
> >
> 
> The folks on the wireless project have concluded that the problem I reported is down to a hardware 
> problem when power saving is switched on on for my Belkin cardbus wireless adapter, so now I simply 
> turn power-saving off when wlan0 comes up. I did, however, ask whether anyone was going to fix the 
> fact that once power-saving turns the LEDs off, they never come back on again, but I haven't had an 
> answer. Is that a regression? I guess the answer is no, because power saving in the rt61pci driver 
> is feature that is new to 2.6.31. Should it be fixed? I think the answer is yes, but being unable 
> to do it myself, I probably don't have a vote :-)
> 
> All I can do is report that I now know how to avoid my laptop freezing and leave the decision as to 
> whether it should stay on the regression list to you and the folks from the wireless project.
Comment 3 Rafael J. Wysocki 2009-08-10 14:04:15 UTC
On Monday 10 August 2009, Chris Clayton wrote:
> Hi Rafael,
> 
> On Sunday 09 August 2009, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.30.  Please verify if it still should be listed and let me know
> > (either way).
> >
> 
> Ivo sent a test patch for this and I tested it., but without success. I reported my findings but 
> didn't get a reply. See http://marc.info/?l=linux-wireless&m=124940189007154&w=4.
> 
> I suspect the failure is due to the same PS hardware probelms that were at the route of my original 
> report.. Unless one of the wireless folks say otherwise, I think we should close this on the basis 
> of busted hardware. I'm happy to simply eject the card and re-insert it now that I have some udev 
> scripts to tear down the wireless configuration on the ejection and set it uop again when the card 
> is re-inserted.

Note You need to log in before you can comment on or make changes to this bug.