Bug 13845 - inotify regression, missing events
inotify regression, missing events
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: io_other
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-07-26 22:15 UTC by Rafael J. Wysocki
Modified: 2009-07-29 21:11 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.31-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-07-26 22:15:32 UTC
Subject    : inotify regression, missing events
Submitter  : Scott James Remnant <scott@ubuntu.com>
Date       : 2009-07-11 16:02
References : http://marc.info/?l=linux-kernel&m=124732816314881&w=4
Handled-By : Eric Paris <eparis@redhat.com>

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Stephen Hemminger 2009-07-27 22:48:18 UTC
I see this on 2.6.31-rc4. I files are moved or added to ~/Desktop
then Gnome nautilus does not see them until a refresh is forced.
Comment 2 Rafael J. Wysocki 2009-07-29 21:10:24 UTC
On Wednesday 29 July 2009, Scott James Remnant wrote:
> On Tue, 2009-07-28 at 16:15 -0400, Eric Paris wrote:
> 
> > On Tue, 2009-07-28 at 00:52 +0200, Rafael J. Wysocki wrote:
> > > On Monday 27 July 2009, Scott James Remnant wrote:
> > > > On Sun, 2009-07-26 at 22:28 +0200, Rafael J. Wysocki wrote:
> > > > 
> > > > > This message has been generated automatically as a part of a report
> > > > > of recent regressions.
> > > > > 
> > > > > The following bug entry is on the current list of known regressions
> > > > > from 2.6.30.  Please verify if it still should be listed and let me know
> > > > > (either way).
> > > > > 
> > > > > 
> > > > > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13845
> > > > > Subject		: inotify regression, missing events
> > > > > Submitter	: Scott James Remnant <scott@ubuntu.com>
> > > > > Date		: 2009-07-11 16:02 (16 days old)
> > > > > References	: http://marc.info/?l=linux-kernel&m=124732816314881&w=4
> > > > > Handled-By	: Eric Paris <eparis@redhat.com>
> > > > > 
> > > > This patch hasn't found its way into Linus' tree yet, so it's definitely
> > > > still an issue and should be listed.
> > > 
> > > Thanks for the update
> > 
> > Looks like it was pulled into Linus's tree last night if you would like
> > to test and verify.
> > 
> Tested and verified, good work!

Note You need to log in before you can comment on or make changes to this bug.