Bug 13838 - kernel BUG at include/net/netns/generic.h:41!
Summary: kernel BUG at include/net/netns/generic.h:41!
Status: CLOSED CODE_FIX
Alias: None
Product: Networking
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Arnaldo Carvalho de Melo
URL:
Keywords:
Depends on:
Blocks: 13615
  Show dependency tree
 
Reported: 2009-07-26 21:15 UTC by Rafael J. Wysocki
Modified: 2009-08-09 23:01 UTC (History)
0 users

See Also:
Kernel Version: commit 78af08d
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-07-26 21:15:09 UTC
Subject    : kernel BUG at include/net/netns/generic.h:41!
Submitter  : Luca Tettamanti <kronos.it@gmail.com>
Date       : 2009-07-20 15:27
References : http://lkml.org/lkml/2009/7/20/105

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-07-28 21:09:40 UTC
On Tuesday 28 July 2009, Eric Dumazet wrote:
> Luca Tettamanti a écrit :
> > On Mon, Jul 27, 2009 at 7:29 AM, Américo Wang<xiyou.wangcong@gmail.com>
> wrote:
> >> On Mon, Jul 27, 2009 at 4:28 AM, Rafael J. Wysocki<rjw@sisk.pl> wrote:
> >>> This message has been generated automatically as a part of a report
> >>> of recent regressions.
> >>>
> >>> The following bug entry is on the current list of known regressions
> >>> from 2.6.30.  Please verify if it still should be listed and let me know
> >>> (either way).
> >>>
> >>>
> >>> Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=13838
> >>> Subject         : kernel BUG at include/net/netns/generic.h:41!
> >>> Submitter       : Luca Tettamanti <kronos.it@gmail.com>
> >>> Date            : 2009-07-20 15:27 (7 days old)
> >>> References      : http://lkml.org/lkml/2009/7/20/105
> >> Hmm, it looks like that 'pfkey_net_id' is still zero after
> ipsec_pfkey_init()...
> >>
> >> Add Herbert and net-dev into Cc.
> >>
> >> Luca, would you mind to provide your .config and the steps to reproduce
> this?
> > 
> > I cannot reproduce it anymore with the current git kernel. The BUG was
> > triggered by racoon at startup.
> > Should I go back to an older kernel to investigate or can we consider
> > it "fixed"?
> > 
> 
> This should be fixed by following patch (submitted for bug 13760, but should
> apply)
> 
> diff --git a/net/core/net_namespace.c b/net/core/net_namespace.c
> index b7292a2..1972830 100644
> --- a/net/core/net_namespace.c
> +++ b/net/core/net_namespace.c
> @@ -488,7 +488,7 @@ int net_assign_generic(struct net *net, int id, void
> *data)
>        */
>  
>       ng->len = id;
> -     memcpy(&ng->ptr, &old_ng->ptr, old_ng->len);
> +     memcpy(&ng->ptr, &old_ng->ptr, old_ng->len * sizeof(void *));
>  
>       rcu_assign_pointer(net->gen, ng);
>       call_rcu(&old_ng->rcu, net_generic_release);
Comment 2 Rafael J. Wysocki 2009-07-28 21:10:58 UTC
Handled-By : Eric Dumazet <eric.dumazet@gmail.com>
Patch : http://patchwork.kernel.org/patch/37779/
Comment 3 Rafael J. Wysocki 2009-08-09 23:01:08 UTC
Fixed by commit 144586301f6af5ae5943a002f030d8c626fa4fdd .

Note You need to log in before you can comment on or make changes to this bug.