Bug 13836 - suspend script fails, related to stdout?
suspend script fails, related to stdout?
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216 13615
  Show dependency treegraph
 
Reported: 2009-07-26 21:01 UTC by Rafael J. Wysocki
Modified: 2010-02-26 20:17 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.31-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-07-26 21:01:12 UTC
Subject    : suspend script fails with 2.6.31, related to stdout?
Submitter  : "Tomas M." <tmezzadra@gmail.com>
Date       : 2009-07-17 21:24
References : http://marc.info/?l=linux-kernel&m=124785853811667&w=4

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-08-26 20:55:04 UTC
On Wednesday 26 August 2009, Tomas M. wrote:
> yes, this is still the case, the same script (netcfg from archlinux) 
> fails during boot too.
> 
> Rafael J. Wysocki wrote:
> 
> This message has been generated automatically as a part of a report
> of recent regressions.
> 
> The following bug entry is on the current list of known regressions
> from 2.6.30.  Please verify if it still should be listed and let me know
> (either way).
> 
> 
> Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13836
> Subject		: suspend script fails, related to stdout?
> Submitter	: Tomas M. <tmezzadra@gmail.com>
> Date		: 2009-07-17 21:24 (40 days old)
> References	: http://marc.info/?l=linux-kernel&m=124785853811667&w=4
Comment 2 Rafael J. Wysocki 2009-09-10 21:02:50 UTC
pasting manually due to the Bugzilla's e-mail interface not working at the moment:

tested rc9 and its still there.

Rafael J. Wysocki wrote:
> This message has been generated automatically as a part of a report
> of recent regressions.
>
> The following bug entry is on the current list of known regressions
> from 2.6.30.  Please verify if it still should be listed and let me know
> (either way).
>
>
> Bug-Entry     : http://bugzilla.kernel.org/show_bug.cgi?id=13836
> Subject               : suspend script fails, related to stdout?
> Submitter     : Tomas M. <tmezzadra@gmail.com>
> Date          : 2009-07-17 21:24 (52 days old)
> References    : http://marc.info/?l=linux-kernel&m=124785853811667&w=4
Comment 3 ykzhao 2009-09-11 02:55:39 UTC
Hi, Tomas
    From the info http://marc.info/?l=linux-kernel&m=124785853811667&w=4 it seems that this is a regression. 
   Do you have an opportunity to use the git-bisect to identify the commit which causes the regression?
   >Inappropriate ioctl for device
    /bin/stty: standard input: Inappropriate ioctl for device
   >:: Scanning for networks    [BUSY] wlan0     Interface doesn't support 
scanning : Network is down

   Is this above message related with the wireless device driver?

   Thanks.
Comment 4 tomas m 2009-09-11 03:51:10 UTC
if i told you i knew how to bisect, id be lying. 

anyway, ive tested today with arch linux's kernel+patches, so the issue is probably going to be more widespread and someone more competent will be able to fill in the gaps i leave. im monitoring the archlinux forums and bug reports.

sorry if im not of much help.
Comment 5 ykzhao 2009-09-21 03:43:27 UTC
Thanks for the info.
   Maybe this issue is related with the wireless driver.

will you please assign this bug to the wireless category? 
   Thanks.
Comment 6 John W. Linville 2009-09-29 18:35:32 UTC
It might be helpful to know what sort of wireless device you have? :-)
Comment 7 tomas m 2009-09-29 22:12:04 UTC
here it goes..

$  lsusb |grep 73
Bus 001 Device 002: ID 0db0:6877 Micro Star International RT2573
Comment 8 John W. Linville 2010-02-26 17:15:08 UTC
This really doesn't look like a wireless problem to me -- more like a problem w/ the distro's scripts.  Do you still have this problem with the current updated version of your distro?
Comment 9 tomas m 2010-02-26 17:24:49 UTC
the scripts have been updated. and even if it still fails differently, im almost certain is due to the fact that the rt73 device is not ready when the script runs.

i think this can be closed now
Comment 10 Rafael J. Wysocki 2010-02-26 20:17:18 UTC
Closing.

Note You need to log in before you can comment on or make changes to this bug.