Bug 13835 - e1000e massive packet loss
e1000e massive packet loss
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: drivers_network@kernel-bugs.osdl.org
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-07-26 20:54 UTC by Rafael J. Wysocki
Modified: 2009-12-07 21:59 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.30.1
Tree: Mainline
Regression: Yes


Attachments
wireshark dump (86.09 KB, application/octet-stream)
2009-10-17 02:49 UTC, Caleb Cushing
Details
tcpdump from faulty kernel (578.82 KB, application/x-gzip)
2009-11-18 09:31 UTC, Caleb Cushing
Details
tcpdump from linksys wrt54gl router (101.01 KB, application/x-gzip)
2009-11-18 09:34 UTC, Caleb Cushing
Details
tcpdump from faulty kernel (3.24 KB, application/x-gzip)
2009-11-24 05:58 UTC, Caleb Cushing
Details
netstat -s before faulty kernel (496 bytes, application/x-gzip)
2009-11-24 06:03 UTC, Caleb Cushing
Details
netstat -s after faulty kernel (496 bytes, application/x-gzip)
2009-11-24 06:03 UTC, Caleb Cushing
Details
tcpdump from linksys wrt54gl router (2.44 KB, application/x-gzip)
2009-11-24 06:07 UTC, Caleb Cushing
Details
ethtool post tcpdump (283 bytes, application/x-gzip)
2009-11-24 06:09 UTC, Caleb Cushing
Details
ethtool -S post tcpdump (401 bytes, application/x-gzip)
2009-11-24 06:10 UTC, Caleb Cushing
Details
netstat -s before faulty kernel (425 bytes, application/x-gzip)
2009-11-25 13:56 UTC, Caleb Cushing
Details

Description Rafael J. Wysocki 2009-07-26 20:54:31 UTC
Subject    : e1000e 2.6.30.1 massive packet loss
Submitter  : Caleb Cushing <xenoterracide@gmail.com>
Date       : 2009-07-16 09:49
References : http://marc.info/?l=linux-kernel&m=124773057917887&w=4
Notify-Also : Eric Dumazet <dada1@cosmosbay.com>
Notify-Also : Linux Netdev List <netdev@vger.kernel.org>

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Caleb Cushing 2009-08-01 16:50:35 UTC
Appears to be fixed in .4 (and just when I was about to not be lazy and bisect the kernel).
Comment 2 Caleb Cushing 2009-10-17 02:49:46 UTC
Created attachment 23440 [details]
wireshark dump

I'd like this reopened. I think it may still exist. it has now become intermittent though. Meaning it doesn't happen every reboot. I find the packet loss about ever other reboot (which is why I didn't notice it immediately I don't reboot often). I can still attempt bisecting if necessary. or get any dump's needed.
Comment 3 Caleb Cushing 2009-10-17 02:53:53 UTC
running kernel26 2.6.31.4-1

I suppose it may be a new bug too.
Comment 4 Caleb Cushing 2009-11-18 09:31:11 UTC
Created attachment 23821 [details]
tcpdump from faulty kernel
Comment 5 Caleb Cushing 2009-11-18 09:34:27 UTC
Created attachment 23822 [details]
tcpdump from linksys wrt54gl router

tcpdump was made filtering by mac address to cut down on noise from windows box's on the network.
Comment 6 Caleb Cushing 2009-11-24 05:58:29 UTC
Created attachment 23908 [details]
tcpdump from faulty kernel
Comment 7 Caleb Cushing 2009-11-24 06:03:15 UTC
Created attachment 23909 [details]
netstat -s before faulty kernel
Comment 8 Caleb Cushing 2009-11-24 06:03:50 UTC
Created attachment 23910 [details]
netstat -s after faulty kernel
Comment 9 Caleb Cushing 2009-11-24 06:07:58 UTC
Created attachment 23911 [details]
tcpdump from linksys wrt54gl router

uname -a
Linux OpenWrt 2.4.35.4 #12 Mon Jun 1 21:52:49 UTC 2009 mips unknown
Comment 10 Caleb Cushing 2009-11-24 06:09:34 UTC
Created attachment 23912 [details]
ethtool post tcpdump
Comment 11 Caleb Cushing 2009-11-24 06:10:10 UTC
Created attachment 23913 [details]
ethtool -S post tcpdump
Comment 12 Caleb Cushing 2009-11-25 13:56:48 UTC
Created attachment 23932 [details]
netstat -s before faulty kernel

Note You need to log in before you can comment on or make changes to this bug.