Bug 13826 - thinkpad boots with backlight low
thinkpad boots with backlight low
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Platform
All Linux
: P1 normal
Assigned To: Henrique de Moraes Holschuh
:
Depends on:
Blocks: 13615 56331
  Show dependency treegraph
 
Reported: 2009-07-25 21:00 UTC by Rafael J. Wysocki
Modified: 2013-04-09 06:23 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.31-rc2
Tree: Mainline
Regression: Yes


Attachments
dmesg output of 2.6.31-rc4 on my IBM X41 Tablet (thinkpad_acpi loaded as module later, with option brightness_mode=2 in /etc/modprobe.d/thinkpad.conf to fix the backlight interaction) (70.74 KB, application/octet-stream)
2009-07-27 07:30 UTC, Tobias Diedrich
Details
acpidump output on my IBM X41 Tablet (73.17 KB, application/gzip)
2009-07-27 07:32 UTC, Tobias Diedrich
Details
Do not use ECNVRAM mode on Intel-based GPUs (4.69 KB, patch)
2009-08-01 14:40 UTC, Henrique de Moraes Holschuh
Details | Diff

Description Rafael J. Wysocki 2009-07-25 21:00:56 UTC
Subject    : 2.6.31-rc2: thinkpad boots with backlight low
Submitter  : Pavel Machek <pavel@ucw.cz>
Date       : 2009-07-15 15:13
References : http://marc.info/?l=linux-kernel&m=124756359126830&w=4
Handled-By : Henrique de Moraes Holschuh <hmh@hmh.eng.br>
Notify-Also : Tobias Diedrich <ranma+kernel@tdiedrich.de>

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 ykzhao 2009-07-27 00:34:23 UTC
Hi, Pavel
    Will you please attach the output of acpidump?
    From the description it seems that this is a regression. Will you please try to use the git-bisect to identify the commit which causes the regression?
    Thanks.
Comment 2 Zhang Rui 2009-07-27 01:20:08 UTC
it seems that the backlight is controlled by thinkpad-acpi driver.

Paval and Tobias,
it would be good if you can attach the acpidump and dmesg of your laptop here.

Paval,
it would be great if you can confirm that the problem on your laptop is same.

Paval does not subscribe to kernel bugzilla?
Comment 3 Tobias Diedrich 2009-07-27 07:30:06 UTC
Created attachment 22506 [details]
dmesg output of 2.6.31-rc4 on my IBM X41 Tablet (thinkpad_acpi loaded as module later, with option brightness_mode=2 in /etc/modprobe.d/thinkpad.conf to fix the backlight interaction)
Comment 4 Tobias Diedrich 2009-07-27 07:32:10 UTC
Created attachment 22507 [details]
acpidump output on my IBM X41 Tablet
Comment 5 Henrique de Moraes Holschuh 2009-07-27 16:50:35 UTC
Confirmed to be a problem in thinkpad-acpi.

The patch is ready (it had been already reported, I will check if it already has a bugzilla entry when I get home).

Will submit the patch later today or early tomorrow, and attach it here.
Comment 6 Rafael J. Wysocki 2009-07-27 22:41:58 UTC
On Monday 27 July 2009, Tobias Diedrich wrote:
> Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.30.  Please verify if it still should be listed and let me know
> > (either way).
> 
> Yes, this still applies to 2.6.31-rc4.
> If I  don't add brightness_mode=2 the backlight controls don't work
> properly.
> 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13826
> > Subject		: thinkpad boots with backlight low
> > Submitter	: Pavel Machek <pavel@ucw.cz>
> > Date		: 2009-07-15 15:13 (12 days old)
> > References	: http://marc.info/?l=linux-kernel&m=124756359126830&w=4
> > Handled-By	: Henrique de Moraes Holschuh <hmh@hmh.eng.br>
Comment 7 Jos van Wolput 2009-07-28 11:25:24 UTC
(In reply to comment #0)
> Subject    : 2.6.31-rc2: thinkpad boots with backlight low
> Submitter  : Pavel Machek <pavel@ucw.cz>
> Date       : 2009-07-15 15:13
> References : http://marc.info/?l=linux-kernel&m=124756359126830&w=4
> Handled-By : Henrique de Moraes Holschuh <hmh@hmh.eng.br>
> Notify-Also : Tobias Diedrich <ranma+kernel@tdiedrich.de>
> 
> This entry is being used for tracking a regression from 2.6.29.  Please don't
> close it until the problem is fixed in the mainline.

I recently bought an Acer Travelmate 4530 AMD Athlon 64 dual-core with ATI Radeon
HD3200 graphics on which I installed Debian/Sid. When using kernels 2.6.30 and 31
the backlight control doesn't work well.
Only occasionly there is /sys/class/backlight and /sys/devices/virtual/backlight/acpi_video, most times these dirs are empty.
Sometimes it boots with backlight very low, sometimes maximum.
When the mentioned dirs are empty there is no control of the backlight, otherwise
the control is buggy, too dark or to light.
When using linux-image-2.6.29 there's no problem with the backlight.
Comment 8 Henrique de Moraes Holschuh 2009-07-28 16:05:21 UTC
(In reply to comment #7)
> I recently bought an Acer Travelmate 4530 AMD Athlon 64 dual-core with ATI
> Radeon

What you describe is a separate problem, please report it as a standalone bug.
Comment 9 Henrique de Moraes Holschuh 2009-08-01 14:40:30 UTC
Created attachment 22568 [details]
Do not use ECNVRAM mode on Intel-based GPUs
Comment 10 Henrique de Moraes Holschuh 2009-08-01 14:41:02 UTC
Patch published, marking FIXED CODE_FIX...
Comment 11 Henrique de Moraes Holschuh 2009-08-01 14:41:48 UTC
Oops, reopening until it hits mainline...
Comment 12 Henrique de Moraes Holschuh 2009-08-02 21:10:19 UTC
Patches sent to mainline by Len Brown, waiting for Linus to merge...
Comment 13 Henrique de Moraes Holschuh 2009-08-03 00:27:57 UTC
merged in mainline, commit 59fe4fe34d7afdf63208124f313be9056feaa2f4.

Now, needs to go to 2.6.30 through -stable.
Comment 14 Henrique de Moraes Holschuh 2009-10-02 20:00:12 UTC
Accepted in -stable, waiting push...

Note You need to log in before you can comment on or make changes to this bug.