Bug 13821 - Replugging USB serial converter uses new device node
Replugging USB serial converter uses new device node
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: drivers_other
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-07-23 22:05 UTC by Rafael J. Wysocki
Modified: 2009-07-28 21:06 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.31-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-07-23 22:05:30 UTC
Subject    : 2.6.31-rc3: replugging USB serial converter uses new device node
Submitter  : Ferenc Wagner <wferi@niif.hu>
Date       : 2009-07-18 20:04
References : http://marc.info/?l=linux-kernel&m=124794754015776&w=4
Notify-Also : Alan Stern <stern@rowland.harvard.edu>
Notify-Also : Kay Sievers <kay.sievers@vrfy.org>
Notify-Also : Alan Cox <alan@lxorguk.ukuu.org.uk>

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-07-27 22:40:09 UTC
References : http://lkml.org/lkml/2009/7/26/233

Reportedly caused by:

commit 335f8514f200e63d689113d29cb7253a5c282967
Author: Alan Cox <alan@lxorguk.ukuu.org.uk>
Date:   Thu Jun 11 12:26:29 2009 +0100

    tty: Bring the usb tty port structure into more use

First-Bad-Commit : 335f8514f200e63d689113d29cb7253a5c282967
Comment 2 Carlos R. Mafra 2009-07-28 17:18:36 UTC
Fixed by c56d300086140c93dc3390e5300fd17df802ec0e in Linus' tree.
Comment 3 Rafael J. Wysocki 2009-07-28 21:06:31 UTC
On Tuesday 28 July 2009, Ferenc Wagner wrote:
> Alan Cox <alan@lxorguk.ukuu.org.uk> writes:
> 
> > commit 3f40612e940971ecec29d5375cdcc9f9c9a9f46e
> > Author: Alan Cox <alan@linux.intel.com>
> > Date:   Tue Jul 28 00:23:39 2009 +0100
> >
> >     tty: USB lock/refcounting fixes
> >     
> >     This fixes
> >     - locking bug that was hidden by ecc2e05e739c30870c8e4f252b63a0c4041f2724
> >     - Regression #13821
> >     - Spurious warning when closing and blocking for data write out
> >     
> >     With these changes my PL2303 always ends up as ttyUSB0 when it should and
> >     the module refcounts stay correct.
> >     
> >     I'll do a more wholesale split & tidy of _open in the next release or two
> >     as we get a standard tty_port_open and port->ops->init port->ops->shutdown
> >     call backs.
> >     
> >     Signed-off-by: Alan Cox <alan@linux.intel.com>
> 
> I confirm that current git (containing the above patch) has regression
> #13821 fixed, as well as the open bug discovered by Alan Stern.

Note You need to log in before you can comment on or make changes to this bug.