Bug 13813 - Hangups in n_tty_read()
Hangups in n_tty_read()
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: drivers_other
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-07-22 20:53 UTC by Rafael J. Wysocki
Modified: 2009-08-03 16:07 UTC (History)
0 users

See Also:
Kernel Version: 2.6.31-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-07-22 20:53:24 UTC
Subject    : Hangups in n_tty_read()
Submitter  : Johannes Weiner <hannes@cmpxchg.org>
Date       : 2009-07-16 18:48
References : http://marc.info/?l=linux-kernel&m=124777019920579&w=4
Notify-Also : Alan Cox <alan@lxorguk.ukuu.org.uk>

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-08-03 15:19:10 UTC
On Monday 03 August 2009, Johannes Weiner wrote:
> On Mon, Aug 03, 2009 at 03:15:10AM +0200, Frédéric Weisbecker wrote:
> > 2009/8/2 Rafael J. Wysocki <rjw@sisk.pl>:
> > > This message has been generated automatically as a part of a report
> > > of recent regressions.
> > >
> > > The following bug entry is on the current list of known regressions
> > > from 2.6.30.  Please verify if it still should be listed and let me know
> > > (either way).
> > >
> > >
> > > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=13813
> > > Subject         : Hangups in n_tty_read()
> > > Submitter       : Johannes Weiner <hannes@cmpxchg.org>
> > > Date            : 2009-07-16 18:48 (18 days old)
> > > References      : http://marc.info/?l=linux-kernel&m=124777019920579&w=4
> > 
> > 
> > Johannes,
> > 
> > Does it still happen with latest mainline?
> > Also, could you send us your .config ?
> 
> I wanted to wait until confirming this as this bug could take a while
> to trigger.
> 
> But v2.6.31-rc4-405-gb592972 seems to be okay, I have it running
> stable for several days now.
Comment 2 Rafael J. Wysocki 2009-08-03 16:07:10 UTC
On Monday 03 August 2009, Johannes Weiner wrote:
> On Sun, Aug 02, 2009 at 03:22:01PM -0700, Linus Torvalds wrote:
> 
> > > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13815
> > > Subject		: emacs -nw compilation doesn't show the error message
> > > Submitter	: Aneesh Kumar K.V <aneesh.kumar@linux.vnet.ibm.com>
> > > Date		: 2009-07-23 06:22 (11 days old)
> > 
> > Same old pty bug, same fix: commit e043e42bdb.
> > 
> > > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13813
> > > Subject		: Hangups in n_tty_read()
> > > Submitter	: Johannes Weiner <hannes@cmpxchg.org>
> > > Date		: 2009-07-16 18:48 (18 days old)
> > > References	: http://marc.info/?l=linux-kernel&m=124777019920579&w=4
> > 
> > Hmm. Worth testing that same fix, although the symptoms here are not 
> > exactly the same.
> 
> Hm, I had no debugging enabled, but I think a silent hang in
> 
> 	pty_write()
> 	  tty_flip_buffer_push()
> 	    flush_to_ldisc()
> 
> can cause the receiving side
> 
> 	tty_read()
> 	  n_tty_read()
> 
> to wait forever for updates.  I haven't looked closely.  It seems to
> be gone with your latest master in any case.

Note You need to log in before you can comment on or make changes to this bug.